Yunohost service do not update to v4 with Buster

After migrating Yunohost to Buster, some parts of the system are up-to-date and working, but yunohost and yunohost-admin are still in v3.8, and don’t want to upgrade to v4:

admin@server:~$ apt list --upgradable
En train de lister… Fait
yunohost-admin/stable 4.0.3 all [pouvant être mis à jour depuis : 3.8.3.5]
yunohost/stable 4.0.3 all [pouvant être mis à jour depuis : 3.8.5.5]
admin@server:~$ sudo apt upgrade
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Calcul de la mise à jour… Fait
Les paquets suivants ont été conservés :
yunohost yunohost-admin

Confirmed by Diagnostic:

Vous exécutez des versions incohérentes des packages YunoHost … très probablement en raison d’une mise à niveau échouée ou partielle.
yunohost version : 3.8.5.5 (stable)
yunohost-admin version : 3.8.3.5 (stable)
moulinette version : 4.0.3 (stable)
ssowat version : 4.0.3+202007291517 (stable)

I tried to install them, but:

admin@server:~$ sudo apt install yunohost yunohost-admin
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l’impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’Incoming.
L’information suivante devrait vous aider à résoudre la situation :
Les paquets suivants contiennent des dépendances non satisfaites :
yunohost : Dépend: python-requests mais ne sera pas installé
Dépend: openssl mais ne sera pas installé
Dépend: ca-certificates mais ne sera pas installé
Dépend: libnss-ldapd mais ne sera pas installé
Dépend: libpam-ldapd mais ne sera pas installé
Dépend: postfix mais ne sera pas installé
Dépend: postfix-ldap mais ne sera pas installé
Dépend: postfix-policyd-spf-perl mais ne sera pas installé
Dépend: postfix-pcre mais ne sera pas installé
Dépend: dovecot-core mais ne sera pas installé
Dépend: dovecot-ldap mais ne sera pas installé
Dépend: dovecot-lmtpd mais ne sera pas installé
Dépend: dovecot-managesieved mais ne sera pas installé
Dépend: dovecot-antispam mais ne sera pas installé
Dépend: rspamd mais ne sera pas installé
Dépend: metronome (>= 3.14.0)
Recommande: python-pip mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».

How can I force the update? Thanks!

apt install openssl=1.1.1d-0+deb10u3 --allow-downgrades
This should do the trick, the install is blocked by an incorrect openssl version.

1 Like

(Note that it should now be handled automagically by the core with the newest version of the migration in 3.8.5.6)

Bonjour
Après un apt update && apt dist-upgrade -y j’avais 3 paquets pas non mis ç jour yunohost ssowat et mulinette
du coup

sudo yunohost tools migrations migrate

Pour la migration bloqué à la 15 j’ai utilisé cette commande

sudo yunohost tools migrations migrate --accept-disclaimer

et ça as bien migré !

Hello ;D
I have the same problem with the upgrade from 3.8.5.6 to 4.0 under Buster.

And to downgrade openssl don’t solve the problem?