Yunohost server completely down

Hi all,
my Yunohost server seems to have a severe problem and I would be very happy for any help.

My YunoHost server

Hardware: VPS bought online
YunoHost version: ??? latest
I have access to my server : through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

Neither the web admin nor the wordpress or nextcloud apps are running. The web admin page only gives this error message:

Der Server hat die Verbindung geschlossen, anstatt sie zu beantworten. Wurde nginx oder die yunohost-api aus irgendeinem Grund neu gestartet oder gestoppt? (Fehlercode/Meldung: 0 error)

My translation:

The server has closed the connection instead of responding to it. Has nginx or the yunohost-api been restarted or stopped for any reason? (Errorcode/Message: 0 error)

My last action was to add two ipv6 subdomain entries to DNS table that had been reported missing by Yunohost diagnosis as a warning. I doubt this is the reason for the error, I removed those entries later.

What I have tried:
I restarted my VPS several times. Once or twice, everything seemed to work for a short while, but the server went eventually down in every case.

I hope for any help for diagnosis. Thank you in advance.

Hello matalb,

For me the best thing to do is to check the logs.

With a SSH access, you may check :
/var/log/yunohost/yunohost-cli.log and yunohost-api.log

and try to find the first error that occur

Have you tried to run :

sudo yunohost diagnosis run

1 Like

Hi Cyril,
thanks for your answer. In the meantime, I already had completely re-installed Yunohost. The data lost are not yet important. But the problems remain.
Luckily, I managed to learn ssh. I connected as admin, the log files couldn’t be accessed: permission denied.

The diagnosis ouput is:
sudo yunohost diagnosis show --issues
description: Email
id: mail
- Current reverse DNS:
Expected value: mydomain.tld
- You should first try to configure the reverse DNS with mydomain.tld in your internet router interface or your hosting provider interface. (Some hosting provider may require you to send them a support ticket for this).
- Some providers won’t let you configure your reverse DNS (or their feature might be broken…). If your reverse DNS is correctly configured for IPv4, you can try disabling the use of IPv6 when sending emails by running ‘yunohost settings set smtp.allow_ipv6 -v off’. Note: this last solution means that you won’t be able to send or receive emails from the few IPv6-only servers out there.
status: ERROR
summary: The reverse DNS is not correctly configured in IPv6. Some emails may fail to get delivered or may get flagged as spam.

This seems only affect email, not the web server.

I tried via ssh: “sudo su” as recommended to get root access right, this didn’t help: no permission to access the log files.

So far, Yunohost is running well. Maybe, the dns changes that I tried before the reinstallation, took some time to become effective.

… but I still cannot get the log files via ssh: permission denied.

I have marked the problem as solved and will post the remaining problems again.

Hi Matalb,

Yes, ssh help a lot.

This is strange that you cannot open your logs.
Have you opened a ssh session with this command ?

ssh admin@IpAdressOrDomainName

And then run this command ?

sudo more /var/log/syslog

Hi Cyril,
yes, I used ssh admin@xxxx, and no, I tried
sudo scp /var/log/syslog ~/syslog e.g.

sudo more /var/log/syslog actually works for me. I am still learning ssh.

Now, I tried again sudo scp /var/log/syslog ~/syslog, it runs without error. Maybe I forgot sudo before. The problem is now, I cannot find the copied syslog.

These seem to be beginner’s problems, I appreciate your help.

1 Like

I’m not sure what this command is doing.
scp is used to copy files with SSH. (
But in your command, it seems you’re copying from var/log to home directory in the same workstation.
You should spend some time on online tutorial and training website ( like this one : )

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.