Yunohost Problems with DualStack-Lite


My YunoHost server

Hardware: Other ARM board (Odroid N2)
YunoHost version: (stable)
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no / yes
If yes, please explain:

Description of my issue

I have an Arm-Board “Odroid N2”, which is similar in speed to the Raspberry Pi4 4GB.
So flashed Armbian Buster for my board to the SD card. as always.
I updated the system (apt update && apt upgrade), and then run the curl script in the YunoHost install guide for other arm boards.
The installation went well and i made it to the welcome screen, created the admin password and a new user.
Everything fine so far.
when i run the diagnosis, I got some erros. You can look them up in the log file.

I did the port forwarding in my router (AMV Fritz!Box 7590) for port 80, 443, 22 for ipv4 and ipv6 and tested them. they are working. I even did tunnel the ports to my ipv6 address on a little VPS server with 6tunnel, because of my DS-Lite (Dual Stack - Lite). And it works too.
I tested the ipv4 adress of my VPS and the ipv6 of my server in a browser on my mobile network (not WLAN). And it directs me to the admin Web interface of yunohost.

So, it works for the ip, but not the domain, I’ve chosen in the post installation setup with
Also the certificate doesn’t work.

My mind is blank. I can’t think anymore.

Please forgive me my bad english in some cases. Native Language is german.
I hope I could explain my problem clearly enough to you.
So, someone may help me please.


Can you confirm that you tested using the global IP and not the local IP ?

Aso what happens if you try to contact your server using its domain name ?

Yes, i used the global ipv6 or the global ipv4 of the VPS I tunneled to the global ipv6 of my server.

When I enter the https domain I get a connection erreor.
But strange is, when I enter the http domain, i don’t get the connection error, but a blank black page.

I misread ‘DS Lite’ as well as ‘port’, got this image in my mind:


… So you mean you’re behind a reverse proxy … ?

How did you “tunnel” the IP

I tunneled the global IPv6 of my YunoHost server on a minimal virtual private server(VPS), I rent on Ionos, with the 6tunnel command.

$: 6tunnel [ipv4 port] [global ipv6 of my armbian board] [ipv6 port]

I did this with the ports 80 and 443.

But I tried something different.
I creatrd manually a new domain with my ipv6 and the VPS’s ipv4 on record AAAA and A.
So it works, kind of.
I can acess the user web panel and the admin panel with the new domain. (On my Mobile Phone at work)
But certificate is not working corectly.

I can test it more after work.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.