YunoHost on CubieTruck / Cubieboard3

en

#1

Hi -
I want to run Yunohost on an CubieTruck / Cubieboard3 .
Has somone used this image successfully??
https://build.yunohost.org/yunohost-stretch-3.0.0-cubietruck-stable.img.zip


#2

Hi @rockyIII

Have you tried or had a problem ?

I don’t think it is officially supported since it doesn’t appear on https://yunohost.org/#/install_fr


#3

I struggled quid few days – the images did not work for me out of the box – but i got it to work.

There is a problem with the password management
Either you can´t login by the web interface or not by the command line… the set password is not synchronized

If you are interested i can explain how i did it at the end…

I have now a working yunohost system on my cubietrack for two days and I´m really happy…


#4

Hi @rockyIII I think it would usefull to all if you explained how you got it to work. And maybe we can integrate some changes to the image itself.

Glad you got it to work.

Sorry I was wrong about “not officially supported” since it appears on https://yunohost.org/#/images_fr (with “needs to be tested”)


#5

I´m a newbie… when i tried to install the given CubieTruck image - I run into problems I solved my try and error -

Here is what i did.:

run the post installation presses by command line

chose a domain name

choose a admin password

than the post installation starts

at the end it says „Yunohost has been configured“

but it does not give you a chance to enter any more… NO ROOT

so this is important now: before you shoot down the server

login by the WEBINTERFACE with the choosen admin password. (if you don´t - you will not be able to login later by the web-interface because the password is not synchronized by some reason)

Now You can pull the plug and reboot the server

By command line you will be asked to login

use „root“ for the username

than you will be asked for a password - use „yunohost“

than you will be asked to chose a new admin password.

Chose the same as you did in the beginning

now you can login to root

update the system by

$ apt-get dist-upgrade

Login by webinterface –

change the admin password

and ad apps

that´s the way it worked for me :wink:


#6

the given yonohost-cubietruckimage comes with “armbian”

https://www.armbian.com/cubietruck/

first - as the given yonohost-cubietruckimage did not work for me I tried an install with

https://dl.armbian.com/cubietruck/Debian_stretch_next.7z

and the description for manual install:

https://yunohost.org/#/install_manually

It gave me a password error as well:

maybe that helps if someone wants to fix the image