Yunohost is not updating anymore - Apt-key signature issue?

:uk:/:us:

My YunoHost server

Hardware: Raspberry Pi (4) at home
YunoHost version: 4.3.6.2
I have access to my server : Through SSH & through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Hello everyone,

I have this issue which needs to be fixed. It would be very kind if anybody has a solution. Every hint is welcome, too.

Description of my issue

I do not know since when my yunohost is not updating anymore. I want to update it again. I do not remember since when or what I did to come to this state.

I did some research now for hours. Is it the system time? Or the apt-key signature? Or some wrong repositories?

I tried to set the time via raspi-config. No success.
I tried this apt-key fixing. Without a change.

I am not sure if there are clone entries in my repositories:

root:~# sudo apt update
Hit:1 http://forge.yunohost.org/debian buster InRelease
Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]      
Get:3 http://archive.raspberrypi.org/debian buster InRelease [32.6 kB]         
Err:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
  Unknown error executing apt-key
Get:4 http://archive.raspberrypi.org/debian buster/main armhf Packages [391 kB]
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://raspbian.raspberrypi.org/raspbian buster InRelease: Unknown error executing apt-key
E: Method store has died unexpectedly!
E: Sub-process store received a segmentation fault.
E: Method /usr/lib/apt/methods/store did not start correctly
root:~# apt-cache policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://forge.yunohost.org/debian buster/stable armhf Packages
     release v=10.0,o=YunoHost,a=stable,n=buster,l=YunoHost for Buster,c=stable,b=armhf
     origin forge.yunohost.org
 500 http://archive.raspberrypi.org/debian buster/main armhf Packages
     release o=Raspberry Pi Foundation,a=oldstable,n=buster,l=Raspberry Pi Foundation,c=main,b=armhf
     origin archive.raspberrypi.org
 500 http://raspbian.raspberrypi.org/raspbian buster/rpi armhf Packages
     release o=Raspbian,a=oldstable,n=buster,l=Raspbian,c=rpi,b=armhf
     origin raspbian.raspberrypi.org
 500 http://raspbian.raspberrypi.org/raspbian buster/non-free armhf Packages
     release o=Raspbian,a=oldstable,n=buster,l=Raspbian,c=non-free,b=armhf
     origin raspbian.raspberrypi.org
 500 http://raspbian.raspberrypi.org/raspbian buster/contrib armhf Packages
     release o=Raspbian,a=oldstable,n=buster,l=Raspbian,c=contrib,b=armhf
     origin raspbian.raspberrypi.org
 500 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
     release o=Raspbian,a=oldstable,n=buster,l=Raspbian,c=main,b=armhf
     origin raspbian.raspberrypi.org
Pinned packages:
     bind9 -> 1:9.11.5.P4+dfsg-5.1+deb10u7 with priority -1
     apache2-bin -> 2.4.38-3+deb10u7 with priority -1
     apache2 -> 2.4.38-3+deb10u7 with priority -1

Please let me know, how I can provide further information, if required. I generated a link with the log ( 20220515-063549-tools_upgrade) but where is that now?

OK - I managed to update yunohost to 4.3.6.3
I commented the raspian repository in

/etc/apt/sources.list

out and went with

sudo apt upgrade yunohost