Yunohost in Proxmox going offline and inaccessible

Hardware: Thinkpad Laptop – Intel i5 – 4GB RAM
YunoHost version: Latest ISO – fresh install
I have access to my server : SSH & Web Admin

Hi there, I’m running YunoHost in Proxmox as a VM. After a few hours, the machine is no longer accessible and appears to be offline even though the VM is running. Does anyone have an idea as to how I can resolve this?

Hi voicoverguy,

Without more information, I wouldn’t. The question is, I think, “Does anyone have an idea how to troubleshoot this?”, in case you did as much troubleshooting as your post implies.

To elaborate on your situation, could you:

  • specify the Yunohost version in your header (“Latest” does not have much meaning tomorrow if you imply Yunohost 11.2.x, especially with Yunohost 12 around the corner. This information is not only for us helping you now, but also for future readers trying to figure out whether your post is relevant for their problem)
  • “After a few hours” : always after 120 minutes, or sometimes in half an hour and another time in half a day?
  • “Appears offline, even though the VM is running” : is it offline, or does it appeear offline (eg, because of routing issues, port mappings or firewall settings)? You can test this by logging in via Proxmox and checking the IP and whether you can ping some locations on your LAN and outside of it.

Additionally: which logs did you read, and how well do you know your way in these logs?

Finally, superficially unrelated to this problem but maybe still part:

These 4GB of RAM, that is all that is available in the laptop, or is it the part that you have allocated to your VM?

I run Yunohosts on Proxmox as well, but all of them as container. A VM in my opinion is only needed to run a system with a Linux-incompatible kernel. By using a container instead of a full VM, you save quite a lot of memory of these few GB you have available!

Good luck troubleshooting :slight_smile:

1 Like