Yunohost do not boot on Raspberry Pi 4


My YunoHost server

Hardware: Raspberry Pi 4
YunoHost version: 4.0.8 (image 2020-10-03)
I have access to my server : Do not boot
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue


I am trying to install Yunohost on a Raspberry Pi 4. I have downloaded the official image (v 4.0.8, image 2020-10-03). I’ve flashed the image using unetbootin (apparently, it was successful). But the Raspberry Pi won’t boot (the led lights stay red, and it does not connect to the network).

Do you have any clue to solve this issue? Does anybody has already successfully
flashed this image?

Thank you for your help,


Can you try with Etcher as recommended in the documentation ? :confused:

Dear Aleks,

Thank you for you suggestion. Actually, using Etcher was my first try. But I got errors (both on Windows and Linux) with Etcher. It simply refuses to flash the img pretending it is corrupted.

I also have tried with an older image (v 4.0.4) and I have the same problem.

Unetbootin does not report any error, though.

Best wishes,


Weeeeell, I would trust Etcher on this and that sounds like a reasonable explanation on why your Pi doesn’t boot …

I don’t know if you’re running Linux (it’s doable also from Windows but a bit more complex) but I would recommend checking the integrity of your file with :


and you should find 3c4978a51aadf1d3804960b5cd39f951ce9cb1b0a2986442281b91167d3deabf

(c.f. )

Also the size of the file should be about 642MB…

Hello again,

Thank you for your suggestion.

Checking the sha256 sum was also one of the thing I did when I realized it did not boot. And the sum was correct.

I’ve also tried the memory card on two different raspberry pi (3 and 4), and none would boot.

I wonder is there is some kind of ‘bootable permission’ that I should check?

Zblerg, I’m always confused about the “boot flags” and so on … From my experience, I don’t trust unetbootin because it has too many options and I’m never sure it sets the boot flag properly, whereas I trust Etcher on this … (though granted it’s a bloated piece of electron software, 100+MB just to flash an sd card, wtf…)

Alternatively, you can try to use Raspberry’s official flashing tool (Raspberry Pi Imager) :

and select a custom image/file in the list before the flash procedure

I never had any bad experience with unetbootin (but I mainly flash standard linux distros). It is a good suggestion to try the Raspberrt’s official flashing tool (I did not even know such a tool was existing).

Thanks for the suggestion. I’ll try it later today and let you know.

Me neither one month ago :sweat_smile: It’s pretty clean and lightweight

Hello i found a solution who worked for me to install yunohost on raspberry pi 4

i downloaded the 64bit iso from raspbian :

then i install it with the raspberry imager :
choose os => use custom

and i install git and docker for arm64 :
git : sudo apt install git
docker :

with the good arch


finally i clone my script with git and then i install it :

git clone && cd yunohost_script && chmod +x && ./ -y

sorry for my english :sweat_smile:

Great, but “the regular install had an issue so I just added an entire docker layer in the mix” is just madness … When your microwave doesn’t work, you don’t fix the situation by buying a brand new castle in spain and buying a whole new set of furnitures and equipement. You just fix the microwave…

Also the Yunohost project generally discourages installing Yunohost inside a docker because Docker is originally meant (or optimized) to host a single app and not an entire OS+ecosystem which Yunohost is.

Not to mention that Yunohost may require additional ports being opened (which means people have to know how to configure docker port forwarding). Also very few people use Yunohost inside docker, which means we have very few experiences/feedback regarding wether or not applications install or fail inside Docker due to Docker specificities.

1 Like

i understand your point, you’re right, for my part is just the only solution i found to get yunohost and openmediavault in a same machine for my nas and divide in two the cost of equipement :pensive:

Dear Aleks,

It turns out that the official Raspberry Pi tool solved the problem.

It might be useful to update the installation guide.

Thank you again for your help,


1 Like

Thank you for your suggestion, but it turned out that the official Raspberry Pi tool solved the issue!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.