Yunohost command not ending v2

Hello all

I have a very similar issue to this thread of the same name.

My YunoHost server

Hardware: Old computer - Mac Mini circa 2014
YunoHost version: 11.1.19 (running on VM via VirtualBox)
I have access to my server :

  • Through SSH
  • through the webadmin (currently hanging)
  • direct access via keyboard / screen (currently hanging)

Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : maybe?

According to this post, setting up Yunohost behind a Fritzbox can be painful.

Description of my issue

What you are trying to achieve

Just as @beelm wrote in his thread of the same name (see above), the YunoHost command seems to have gotten stuck.

I want to get my yunohost command unstuck by finding the currently running process that is not ending. Thanks to @beelm and @aleks I have had several good leads to try (see below) but haven’t been able to resolve it yet.

Ultimately I want to use my yunohost web admin panel as normal - currently it hangs whenever I try to do anything.

The context
Several things happened yesterday in my install/config trial and error before yunohost admin locked up. I include them all below in case anything jumps out for folks reading (or struggling with their own setup).

IPv6 troubleshooting: Changed settings in router (Fritzbox)
Settings I changed include:

  • Editing DynDNS setup in Fritzbox (using dynv6.com) and this tip Note: I didn’t follow the part in these instructions about editing the ‘/etc/network/interfaces’ file in Debian/yunohost
  • Temporarily moving yunohost from being an exposed host to a regular machine on the network. Result: couldn’t SSH into yunohost, so changed it back (permission denied on ports 22 and 27, and couldn’t manage to successfully open them on Fritzbox). So I changed it back to an exposed host.
  • Allowing ipv6 access to yunohost exposed host behind Fritzbox (previously only IPv4 access was allowed)
  • Allowing ping6 to exposed host in Fritzbox
    I’ll document these separately and in more detail on @umrath’s thread about Fritzbox, in case they help anyone else.

IPv6 troubleshooting: Changed settings in yunohost
I reloaded the firewall, using

sudo yunohost firewall reload

Before this, according to yunohost on the command line (could ping6 to and from yunohost), IPv6 was working on yunohost, but diagnostics run in the YH web admin was still giving an error that IPv6 was not available.
After reloading firewall, IPv6 was not working (ping6 out giving error unreachable) on command line or web admin.

First backup: A stalled backup
Yunohost hung yesterday while I was creating the first backup (better late than never :melting_face:) via the command line and SSH. It hung during the process of backing up nocodb (I didn’t collect logs and don’t have the terminal window open anymore, my bad :face_with_peeking_eye:). After about an hour of waiting and nothing happening, I got a command prompt back by pressing command + C

Finalise Vaultwarden setup: add server admin token
I had previously installed Vaultwarden, but only yesterday found the correct token, using these instructions.

Since then, any other process I have tried in yunohost via the command line or the web admin gives the error ‘another process is running’ and after some time fails.

I am new to server side, and I’m aware could be an operator error issue. :grimacing:

What I tried
Following @aleks instructions to @beelm, I have tried the following steps to get yunohost ‘unstuck’.

Attempt 1

Step a: run @Aleks recommendation:

ps -ef | grep -B2 wget

Result a:

nqo      2375838 2375836  0 00:43 pts/1    00:00:00 -bash
nqo      2375889 2375838  0 00:44 pts/1    00:00:00 ps -ef
nqo      2375890 2375838  0 00:44 pts/1    00:00:00 grep -B2 wget

Step b: kill wget job ID:

kill 2375838

Result b:

Nothing obvious happens. No logs appear, process apparently isn’t stopped. Because then I tried…

Attempt 2

Step a: run @Aleks recommendation:

cat /var/run/moulinette_yunohost.lock

Result a:

508

Step b: Run @Aleks recommendation:

$ ps -ef | grep 508

Result b:

nqo      2375969 2375838  0 00:48 pts/1    00:00:00 grep 508

Attempt 3

Step a: run @Alek’s recommendation:

sudo cat /var/log/yunohost/categories/operation/ ls -thor

Result a:

cat invalid option -- 'h'

Returned error message

Warning: Another YunoHost command is running right now, we are waiting for it to finish before running this one
Warning: Still waiting…
Warning: Still waiting…

My questions are:
Resolving immediate issue question

  • Do you have another route to suggest @Aleks or others to stop the hung process?

Future best practise questions

  • Could I have made trouble for my yunohost and myself by control + c out of the hung backup? In other words, does yunohost get broken/confused by cancelling out of a running process?
  • If yes, what is the better way of getting a command prompt when yunohost has gone for a long walk?
  • Could the backup potentially be too big and clogging up my system, and could this be contributing the error? If yes, how do I safely remove the partial backup?

Planned next steps

  • Document the Fritzbox trials on @umrath’s thread.
  • Set up one or two remote storage devices for my yunohost. Perhaps one to hold hold backups and another to hold media+personal files+emails+messages.

Thanks for reading! :rainbow:

Please reply if you have hunches about how I can stop the hung yunohost process.

If you are not running this stuff as root, you should use sudo in front of ps -ef :

sudo ps -ef | grep <the PID>
1 Like

Thanks @Aleks!

Attempt 4

Step a:

sudo ps -ef | grep 508

Result a:

root         508       1  0 May20 ?        00:16:55 /usr/bin/python3 /usr/bin/yunohost-api
root     2352634     508  0 Jul16 ?        00:00:00 sh -c /bin/bash -x "./install"  7>&1
root     2385087 2385065  0 Jul17 ?        00:01:35 /usr/bin/python3 /usr/bin/yunohost diagnosis run --email
root     2401508 2401067  0 Jul17 ?        00:00:27 /usr/bin/python3 /usr/bin/yunohost diagnosis run --email
nqo      2409512 2409447  0 00:30 pts/1    00:00:00 grep 508

This embarrassingly makes sense. Now I know more about what is happening, I recognise that back in May my yunohost VM had a hung process that has made it impossible to do anything via the terminal on the machine. When it happened, I shrugged and started SSHing in using another machine instead.

I’m looking forward to resolving all these and getting into better habits.

Is it safe to kill these processes?
And would I need to: sudo kill for each one individually?

The one taking the lost is in particular the one corresponding to PID 508, or in particular its child with PID 2352634 corresponding to some app install started on Jul 16

It’s probably safe to kill PID 2352634 with :

sudo kill -9 2352634

then wait a couple minutes and if yunohost is still locked, try sudo systemctl restart yunohost-api

1 Like

@Aleks

sudo kill -9 2352634

It worked! Thank you! :tada:

For my - and everyone else’s - understanding, would you share what ‘-9’ does before the child PID in this context?

You can kill processes in different fashion (there are different ways or technical implications under the hood), basically ranging from “asking politely a process to clean up its stuff go back home as soon as it can” and “using a shotgun”. -9 is the shotgun

2 Likes

Helpful context, thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.