Yunohost broken after update



I tried to update yunohost from the admin interface, it crashed with no explicit error message…
I connected via ssh, Iapt-get update then upgrade but mysql-community-server was “broken or partially installed” I tried dpkg-reconfigure, apt-get install -f, apt-get install --reinstall but nothing worked, I finally apt-get removed it, I’ve been proposed to migrate toward mariaDB, I replied “why not ?”.

Now when I do apt-get install I have P aramétrage de libnginx-mod-http-auth-pam (1.12.2-1~dotdeb+8.1) …
nginx: [emerg] unknown directive “access_by_lua_file”
and cascading errors

Nginx -V says --add-dynamic-module=/usr/src/builddir/debian/modules/nginx-lua

but ls /usr/src return nothing !

I feel like it would be a good idea to take a fresh start…
Is there a way to backup all that with a yunohost command ?

Hi @freezix ,

The command in order to backup from CLI -and more- is here in the doc’ :

Edit @freezix :

apt update && apt dist-upgrade && apt install -f