Yunohost behind a Proxy


Hello Yunohost team, and thanks for the great work ! I’ve got a problem and the information I found here where old (Debian 9).

My YunoHost server

global context : home hosting
Hardware: Laptop HP Probook 430
YunoHost version: 11.1.15
I have access to my server : Through SSH, through the webadmin and if needed, direct access via keyboard / screen
Specific context: My Yunohost server is behind an OpnSense box. I want the server to use a whitelist proxy to access internet (updates, app installation…)
tweaking on my YunoHost instance : I use “systemctl edit yunohost-api” to add a HTTPS_PROXY environment variable

Description of my issue

I put Yunohost on a fresh installed netinst debian, behind a firewall/proxy.

I monitor on my firewall the way Yunohost server try to connect to internet (for updates for exemple).
After adding environment “HTTPS_PROXY” for yunohost-api, it correctly use the proxy and the app catalog is successfully loading.
But if I try to display the detail of an app, I see a git subprocess of yunohost-api who try to directly access to, without using the proxy server.

On the same machine, if I try a git command on after setting manually a “HTTPS_PROXY” environment, it correctly use the proxy server.

It looks like Yunohost-api doesn’t pass the environment to the git subprocess.

It would be great if you verify the way environment is pass to subprocess, or to inform how to configure a proxy !


In fact, I realy believe that yunohost-api don’t pass environment variable to subprocesses.

For being able to display the detail of an app, I must alter the git config :


      proxy = http://<proxy_@ip>:<proxy_port>

I also did it for wget, used for installing apps :



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.