Yunohost answering with 502 on all pages

My YunoHost server

Hardware: Virtual machine in a computer
YunoHost version:
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : nothing more than what’s mentioned in the hardware part

Description of my issue

I’m having a strange issue, if someone has some clue on how I could debug the situation, it would be very appreciated.
Basically, all apps (including yunohost sso and admin) are answering with 502.

Side info that could be of some use:

  • Yunohost diagnosis says everything ok, nothing different than when all was working
  • Running curl vmname from the host answers: curl: (7) Failed to connect to vmname port 80: Connection refused (I have other yunohost vms in the same host which work and answer with 302 FOUND to this command)
  • I tried checking nginx logs, latest access and error log files are empty

A week ago, I updated to the newest yunohost version, everything was working fine. I didn’t do more in the meantime. Today I discovered the problem, tried updating again in hope of a miracle, it went well but didn’t have an impact on the issue.

Any idea on things I could look into to try to understand what’s going on would be very appreciated :slight_smile:

Ok, seems related to this issue again, forgot even about it. I guess it happened again because the yunohost update must have changed the nginx config and canceled the changes I had made to them.

A little improvement on the conclusion of the mentioned post:
To avoid having the issue coming back, probably it’s more sensible to add the following lines:

set_real_ip_from 192.168.xx.xx;
real_ip_header X-Forwarded-For;

in a newly created file in /etc/nginx/conf.d/, this way it shouldn’t be deleted by yuonohost in an update.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.