YunoHost 11 migration success!... but dnsmasq fails miserably

Hi everyone / salut tout le monde!

Pleased to report that my server migration has gone through quite easily, thanks to everyone who have worked hard on making it as smooth as possible.

My YunoHost server

Hardware: Old dell laptop at home
YunoHost version:
I have access to my server : Through SSH + through the webadmin + direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : not sure, except that I’m using a static IP with the Network Manager

Description of my issue

I’m struggling with one point dnsmasq fails. I have checked the forum and seen a few potential solutions but it doesn’t work for me…

Pastebin here >

Also the error log >

Hope this will speak to someone!

After discussing this in other threads, this should do the trick:

sudo cp /etc/init.d/dnsmasq.dpkg-dist /etc/init.d/dnsmasq

then restart dnsmasq and it should be up

Thank you so much for taking the time for this. It’s much appreciated!

I’ll definitely give it a go ASAP and post back the results here.

In the meantime, I’ve had to migrate the server to a VPS to keep things going.

Worked perfectly!

One thing to check in addition if there’s a connectivity issue: the resolv.dnsmasq.conf file must have a list of nameservers. Format is one line for each
nameserver: <IP>

Thank you @Aleks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.