Yunhost upgrade not working via the admin gui

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.1.5
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I’m trying to make the following system upgrades in the admin GUI:

  • moulinette (from 11.1.0 to 11.1.4)
  • yunohost-admin (from to 11.1.4)
  • yunohost (from 11.1.5 to

I’m getting the following error:

Error: "400" Bad Request

Action: "PUT" /yunohost/api/upgrade/system

Error message:
You cannot do this right now because dpkg/APT (the system package managers) seems to be in a broken state... You can try to solve this issue by connecting through SSH and running `sudo apt install --fix-broken` and/or `sudo dpkg --configure -a` and/or `sudo dpkg --audit`.

When I run:

$ sudo apt install --fix-broken

I get the following:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up yunohost (11.1.5) ...
Regenerating configuration, this might take a while...
Traceback (most recent call last):
  File "/usr/bin/yunohost", line 77, in <module>
  File "/usr/lib/python3/dist-packages/yunohost/", line 41, in cli
    ret = moulinette.cli(
  File "/usr/lib/python3/dist-packages/moulinette/", line 111, in cli
  File "/usr/lib/python3/dist-packages/moulinette/interfaces/", line 477, in __init__
    self.actionsmap = ActionsMap(
  File "/usr/lib/python3/dist-packages/moulinette/", line 463, in __init__
    self.parser = self._construct_parser(actionsmap, top_parser)
  File "/usr/lib/python3/dist-packages/moulinette/", line 630, in _construct_parser
KeyError: 'arguments'
dpkg: error processing package yunohost (--configure):
 installed yunohost package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I’m not sure what else to try, any help or ideas would be much appreciated! :smile:

Hmmm maybe let’s first force the upgrade of moulinette with apt install moulinette

TLDR; it got resolved somehow, sorry for wasting your time! :blush: :sweat_smile: :heart_hands:

I tried $ sudo apt install moulinette and it said:

moulinette is already the newest version (11.1.4)

Then I went to the web-admin GUI and there were no system updates listed. I’m not sure what happened! I rebooted the server last night and it was late, I’m not sure what I did or how it resolved itself. I wonder if was something to do with low disk space. Anyhow, I appreciate you trying to help @Aleks! :heart: :sun_with_face: :smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.