Your local network does not seem to have hairpinning enabled. what does that mean?

I apologize for any rules that I am breaking, but this is just so frustrating.
Hairpinning? Really?
Just when you think you have this “:EASY SERVER SETUP” finished, you get HAIRPINNING.
I have UPNP enabled in my router.
Trying to OPEN port 1900 I get the message that Port1900 cannot be openen because it’s already CLOSED.
That’s the reason I’m trying to open it, isn’t it?
I know someone will come with a lectyure about how I should have read this or researched that, but the instructions for setup worked fine until Hairpinning and I almost started laughing, because I thought it was a joke. I’ve never heard this term b4,.and i’m frustrated and stuck and I would very much appreciate some help


OK, if you need so, I will be that guy. Being frustrated does not grant you the right to elude the template for support (you know, the wall of text that is in your way when you create a support thread), nor your due diligence right of searching for new unknown technical terms.

That being said…

Some information on hairpinning, from our own documentation: Local network access to your server | Yunohost Documentation .Wikipedia has a nice page about it too. Basically, your router does not allow your requests from within your local network towards your name domain to “loop back” to your local server. It is annoying but not critical. I think there are threads on the forum that offer workarounds.

Regarding UPnP, if I recall correctly it is a bit tricky with some routers, do check that they are indeed openened and do not blindly rely on it.

Why do you need port 1900 opened? Which app requires it? Where does it say it is closed while you try to open it?


As I said, I apologize for my frustration but having to look up every second word in the dictionary is frustrating, I’m not a complete noob, but i’ve been operating in the Microsoft world since MS Dos
The reason I am here is because this was supposed to be an easy server install.
Learning English as a second language was child’s play compared to this. And I’ve been on several forums where people(including myself) were asking questions because they didn’t have another option.
The first response is usually “this question doesn’t belong here , you should have posted it …”
second response is usually "if you read this article or watched this video on youtube, you would know the answer.
third response is an actual attempt to answer the question posed , and the the fourth is someone contradicting said answer and things devolve into and online argument.
Not saying this always happens, but i’ve seen it more often than I care to remember.and that is why I usually avoid forums like the plague.

Anyways, I ran the diagnostic in the user interface and it showed UPNP disabled and when I click to enable i get the error message about port 1900 being closed. When I attempt to open port 1900 it tell me that it is already closed.
hence the frustrations.
All in all it is an easy setup until the part where the program lets go of your hand and you have to configure port forwarding and ddns and all that.
But I will persevere,lol
Thanks for letting me vent

This is the official support forum for YunoHost. Welcome again! :wink:

You failed to disclose which app you installed, but no worries I found out: Jellyfin. You can safely Ignore the warning, it is a slight bug with YunoHost which does not discriminate between ports opened on TCP or UDP. (Same issue with WireGuard here).

Yup, these actions have to be done manually, because they are out of the reach of the software (it is like asking your car to repave a road, that is not its job).
Regarding dynamic dns, the documentation is helpful I think. Regarding standard DNS; we will soon be able to configure them with some registrars programmatically. :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.