Xwiki fails to start or is not accessible / editing service file not sufficient?

My YunoHost server

Hardware: VPS online /
YunoHost version: (stable)
I have access to my server : ssh, web admin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I wanted to try out the xwiki app, but it eventually fails to start up completely, it seems.
When clicking on the link to open it, the website first displays a loading indication, but eventually displays this warning:

502 Bad Gateway

If you see this page, your connection with the server is working but the internal service providing this path is not responding.

Administrator, make sure that the service is running, and check its logs if it is not. The Services page is in your webadmin, under Tools > Services.

Thank you for using YunoHost.

So I went to the services tool just to find out the service seems still be running.
Then I connected via ssh and did journalctl _AUDIT_TYPE_NAME=SECCOMPwhich returned a list of log entries corresponding with the time of clicking on the xwiki link:

Jan 13 22:04:44 progs4sustainability.de audit[1880623]: SECCOMP auid=4294967295 uid=977 gid=977 ses=4294967295 subj==unconfined pid=1880623 comm=4A6F62207374617475732073657269 exe="/usr/lib/jvm/java-17-openjdk-amd64/bin/java" sig=31 arch=c000003e syscall=93 compat=0 ip=0x7f7c14656777 code=0x80000000

Since I got there via linux - Troubleshoot a systemd service crash because of SystemCallFilter= - Unix & Linux Stack Exchange I then looked up what syscall=93 would be:

93	common	fchown			sys_fchown

So I edited the file /etc/systemd/system/xwiki.service and added fchown to the line defining SystemCallFilter.
Then stop service, daemon reload, start service: still the same error. Even the same error in the log file. And as previously, the service seems still running.

name@host:/etc/systemd/system$ systemctl status xwiki.service
● xwiki.service - xWiki
     Loaded: loaded (/etc/systemd/system/xwiki.service; enabled; vendor preset: enabled)
     Active: active (running) since Sat 2024-01-13 22:16:09 CET; 22min ago
   Main PID: 2192416
      Tasks: 68 (limit: 9509)
     Memory: 555.9M
        CPU: 1min 12.115s
     CGroup: /system.slice/xwiki.service
             ├─2192416 java --add-opens java.base/java.lang=ALL-UNNAMED --add-opens java.base/java.util=ALL-UNNAMED --add-opens java.base/java.concurrent=ALL-UNNAMED -Xmx1024m -Dxwiki.data.dir=data -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=data -Dje>
             ├─2192451 /bin/bash start_xwiki.sh -p 31386 -sp 31387 -ni
             └─2195778 sleep 1

I suspect the solution is somewhere else, or I completely mismanaged to edit the service file??



The previous version was not working. So please try again with the last package version it should work better since this merge.

perfect! This works excellent now, many thanks! :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.