XMPP - Setup Metronome to deliver messages on all the clients

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version: (stable)
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue


I use XMPP but noticed that if I read a message on my laptop client, it will not appear on my mobile one.
Therefore, the discussions have blanks on both devices.

The only related post I found is this one:

I preferred to create a new one as it is now pretty old and maybe not accurate anymore.
The suggested solution there was:

you can activate the message_carbon plug-in manually in your Metronome’s configuration

But I couldn’t find info about this.

Can someone confirm what should be done in order to synchronise all the XMPP clients please?

Thank you


So I found out that carbon was enabled by default on Metronome.
I don’t understand why I have this issue between my clients… (Conversations and Dino)

I think your answer lies to this explanation https://xmpp.org/extensions/xep-0280.html as this XEP is experimental. This might mean that your clients might not support it (yet).

It seems that they all do from what I read.
Maybe some bug on one or the other side…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.