XMPP/DNS errors

, ,

My YunoHost server

Hardware: Old laptop
YunoHost version: 4.1.8
**I have access to my server : SSH/webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : not (yet) on XMPP/DNS.

Hi there.

I’ve got some XMPP connection problems between my server and some of my contacts’ one. I’ve got a MUC room with some of them inside, and, when I connect my client and thus join this room, they’re ejected with such a message:

remote server not found → Server-to-server connection failed: DNS resolution failed

I guess that’s always at this time because, when my client connect, it forces my server to check if the contacts are online, and then try to find their server. But there’s no DNS problem to their server for any other application I tried, that’s only with XMPP.

(I even tried to add their server’s IP to my /etc/hosts, but it didn’t work –i read that XMPP requests doesn’t use this file)

There’s also some MUC room on other servers I usually join at login that sometimes can’t be found. I guess it should be the same problem, but I don’t have exact logs for them –and, of course, maybe some of my contacts are marked offline for the same reason, but I didn’t figure it out yet because I don’t have the room-leaving message for them.

I don’t know exactly which logs I’m supposed to check in such a case, so, any help would be welcome.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.