Www. does not work

Sorry but I don’t use the template for this one cause it, is a Yuno error depending on the software which I use the latest version of. However, if I go to my domain i.e. easycompzeeland.nl it routes fine trough to the site. But put www. In front of it and it won’t, I added an A record to my DNS which contains www. So it redirects now to /younohost which I don’t want to it just needs to go to the site, is there anything I missed? Host file maybe? Thanks for your suggests!

A little off-topic question; We used our own A.I. to translate it to French, much better than any google or bing API will ever do. So if your language is French, would you please be kind to take a glance at it and please DM me with your feedback. https://easycompzeeland.nl/fr

The www. is a domain on its own. You can have a different app on www.
You should add
To the domains in yunohost and redirect it to the website.
And about the French of the website, it’s not perfect, some sentences need to be rewriting.

Hmm, a dirty solution feels like using an .htaccessfile :wink:

About the FR parts which need review can you send me a DM with an English explanation, our A.I. still needs to learn. :slight_smile:

1 Like

Jarod is right, but forgot mention the Redirect app that does just that :stuck_out_tongue: :

  • domain: www. (to be added beforehand in the Domains menu)
  • path: /
  • redirection location: your main domain address without www at the beginning
  • mode : either “Visible redirect (301, permanent). Everybody will be able to access it.” or “Proxy, invisible (nginx proxy_pass). Everybody will be able to access it.”. First option automatically changes the address from www to your main domain, while the other keeps it.

Thanks for mentioning the redirect app for this case!

1 Like

What it did not work? It caused a loop on my home page.

First you need to generate a Let’s Encrypt certificate for your www domain. Then we will see what’s your actual problem. Please explain to us how you configured the Redirect app.

I did that, but I have other urgent things right now, :wink: thanks for the feedback tough.

Is there a hardcode way to implement this, since it is a necessity? So that a www. version is always presented?

NOTE TO SELF :see_no_evil: Uh, duh, I could just always add www. to a domain…

No, since it is not a necessity. :slight_smile: www subdomains are merely a habit, but nothing forces you to use one.

So yeah, do that. :wink:

1 Like

Uhm, SIDN the Dutch domain company does require me to provide a www.domain.ltd, so actually they force me else I will be fined… yup, that’s a registrar rule.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.