WriteFreely login

updated tyo Yunohost 11 in order to ### My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.0.6 (testing)
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: Upgraded to Yunohost 11 in order to get email working properly on secondary domain. This did not work under Yunohost 4.3

Description of my issue

I’ve installed WriteFreely via the Yunohost Applications web UI. Its seems to be running fine, but I cannot log in to actually use it! WriteFreely appears as an app tile in the user dashboard, and the service loads when I click that tile, but I cannot log in to write any content for it!

I was expecting it to be set up with an admin account and/or user accounts matching my Yunohost users, but I canniot log in with admin or user credentials.

How do I set up a WriteFreely user for a brand new installation in Yunohost? Is there a default admin password to get started with?

strange. doesn’t appear to be a default user name?

did you try your yunohost admin account name/pass or admin/(yunohost admin pass)?

I’ve tried logging in with my Yunohost admin account, and I’ve also tried my personal account in my Yunohost.

When WriteFreely loads, it displays my personal account username at top of the page - however it says incorrect password when I try to use my Yunohost account password to login.

I can only imagine that it has created a user account with my Yunohost username - so far so good - but I have no idea what the password is for that account. And I cannot login with my admin credentials. So I’m stuck!

Based off the app’s manifest, you should have been asked to select an admin user and type your own password during installation.

If you have forgotten it, your admin username is given by the command echo $(sudo yunohost app setting writefreely admin)

To reset the password:

sudo su
cd /var/www/writefreely
sudo -u writefreely writefreely --reset-pass $(yunohost app setting writefreely admin)

Source: app’s manifest and Writefreely’s documentation

1 Like