Write access over sftp

Try to upload files for Airsonic media server, though over the interface as well as over sftp I encounter a write prtection issue: Airsonic - Music media streamer

I also tried this: shutdown the server, removed the sd card from the raspi, connected it to the PC with an usb adapter and tried to move the files manually to the sd card.

Anyone an idea about this?

Je ne connais pas Airsonic, mais cela doit provenir des propriétaires/droits sur les fichiers/répertoires d’origine et/ou de destination.
Je ne suis pas sûr que ce soit une bonne idée, mais il y a un échange ici sur “autoriser root en sftp”.
Traduction deepl.com
I don’t know Airsonic, but it must come from the owners/rights on the original and/or destination files/directories.
I’m not sure it’s a good idea, but there’s an exchange here on “allow root in sftp”.

Thanks for your reply!

It gave me some ideas and finally I solved the problem by accessing via local IP using sftp.

I changed permissions on my media folders. I can access through ftp but it still wont let me do it through the interface.

What kind of permissions? You might need to add them to the “www-data” group if you want the web UI to be able to access them. Or perhaps you need to allow the ftp user also? Tricky stuff, those permissions :wink:

1 Like

I have a bead running ubuntu 14.04 and a LEMP stack. I have subdomains on the/var/www organizer with each having its very own envelope inside/www. I have one client with root authorizations that is the one that I use for ssh and sftp. When I trie to compose the document by means of sftp I have authorization denied.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.