Wordpress fails to install on rpi with YH OS

My YunoHost server

Hardware: Raspberry Pi 4B
YunoHost version: 11.0.9
I have access to my server : through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no, straight from the image, no SSH, modifications, nada.

Description of my issue

I wanted to install WordPress. After YH post-instalation, diagnosis, SSL certificate for my domain and creating a user I browsed for WP app and clicked “install”. After about half of minute the installer quit with a error msg: “An error occurred inside the app installation script”

Here is the log
Here is my diagnosis

Thanks in advance,
Rastko

Hi,

I have tried intalling WP again a couple of times and I allways recive the following error message:

I ran the recommended commands in terminal via ssh and nothing changes.
I received the same message when I tried to install another app. Basically I cannot install anything.

Could this be because before this YH installation from a flashed image I first performed an YH install on top of raspberry pi OS which didn’t work. Could it be that the issue is not on my side (raspi or YH program) but on the side of YH service and something to do with multiple user names or domains I have created while trying to solve the issue and caused a conflict?

Thank you,
Rastko

E: Package 'php8.0-json' has no installation candidate

It looks like the PHP extension for JSON is now included in PHP8.0, per JSON extension is always available - PHP 8.0 • PHP.Watch.

Can you try installing with this potential fix? sudo yunohost app install https://github.com/YunoHost-Apps/wordpress_ynh/tree/json-dep -f

Thank you Tituspijean,

I have tried the command you posted and it returned the same msg as on the above screenshoot:

“You cannot do this right now because dpkg/APT (the system package managers) seems to be in a broken state… You can try to solve this issue by connecting through SSH and running sudo apt install --fix-broken and/or sudo dpkg --configure -a.”

I have tried again both commands listed in the error msg.
For the first the answer in terminal was: “E: Sub-process /usr/bin/dpkg returned an error code (1)”. Second command gave a longer answer:

"Setting up php7.4-common (7.4.33-1+deb11u1) …
debconf: DbDriver “config”: /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing package php7.4-common (–configure):
installed php7.4-common package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of php7.4-curl:
php7.4-curl depends on php7.4-common (= 7.4.33-1+deb11u1); however:
Package php7.4-common is not configured yet.

dpkg: error processing package php7.4-curl (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.4-mysql:
php7.4-mysql depends on php7.4-common (= 7.4.33-1+deb11u1); however:
Package php7.4-common is not configured yet.

dpkg: error processing package php7.4-mysql (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.4-fpm:
php7.4-fpm depends on php7.4-common (= 7.4.33-1+deb11u1); however:
Package php7.4-common is not configured yet.

dpkg: error processing package php7.4-fpm (–configure):
dependency problems - leaving unconfigured
Setting up x11-common (1:7.7+22) …
debconf: DbDriver “config”: /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing package x11-common (–configure):
installed x11-common package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of php7.4-readline:
php7.4-readline depends on php7.4-common (= 7.4.33-1+deb11u1); however:
Package php7.4-common is not configured yet.

dpkg: error processing package php7.4-readline (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.4-mbstring:
php7.4-mbstring depends on php7.4-common (= 7.4.33-1+deb11u1); however:
Package php7.4-common is not configured yet.

dpkg: error processing package php7.4-mbstring (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.4-cli:
php7.4-cli depends on php7.4-common (= 7.4.33-1+deb11u1); however:
Package php7.4-common is not configured yet.
php7.4-cli depends on php7.4-readline; however:
Package php7.4-readline is not configured yet.

dpkg: error processing package php7.4-cli (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfonts-utils:
xfonts-utils depends on x11-common; however:
Package x11-common is not configured yet.

dpkg: error processing package xfonts-utils (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.4-intl:
php7.4-intl depends on php7.4-common (= 7.4.33-1+deb11u1); however:
Package php7.4-common is not configured yet.

dpkg: error processing package php7.4-intl (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfonts-base:
xfonts-base depends on xfonts-utils (>= 1:7.5+2); however:
Package xfonts-utils is not configured yet.

dpkg: error processing package xfonts-base (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfonts-encodings:
xfonts-encodings depends on x11-common; however:
Package x11-common is not configured yet.

dpkg: error processing package xfonts-encodings (–configure):
dependency problems - leaving unconfigured
Setting up php8.0-common (1:8.0.25-1+0~20221028.43+debian11~1.gbpb9995e) …
debconf: DbDriver “config”: /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing package php8.0-common (–configure):
installed php8.0-common package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of php7.4-ldap:
php7.4-ldap depends on php7.4-common (= 7.4.33-1+deb11u1); however:
Package php7.4-common is not configured yet.

dpkg: error processing package php7.4-ldap (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.4-opcache:
php7.4-opcache depends on php7.4-common (= 7.4.33-1+deb11u1); however:
Package php7.4-common is not configured yet.

dpkg: error processing package php7.4-opcache (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-common:
xserver-common depends on x11-common; however:
Package x11-common is not configured yet.

dpkg: error processing package xserver-common (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.4-gd:
php7.4-gd depends on php7.4-common (= 7.4.33-1+deb11u1); however:
Package php7.4-common is not configured yet.

dpkg: error processing package php7.4-gd (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libice6:arm64:
libice6:arm64 depends on x11-common; however:
Package x11-common is not configured yet.

dpkg: error processing package libice6:arm64 (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.4-json:
php7.4-json depends on php7.4-common (= 7.4.33-1+deb11u1); however:
Package php7.4-common is not configured yet.

dpkg: error processing package php7.4-json (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php7.4-xml:
php7.4-xml depends on php7.4-common (= 7.4.33-1+deb11u1); however:
Package php7.4-common is not configured yet.

dpkg: error processing package php7.4-xml (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php8.0-xml:
php8.0-xml depends on php8.0-common (= 1:8.0.25-1+0~20221028.43+debian11~1.gbpb9995e); however:
Package php8.0-common is not configured yet.

dpkg: error processing package php8.0-xml (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php8.0-mbstring:
php8.0-mbstring depends on php8.0-common (= 1:8.0.25-1+0~20221028.43+debian11~1.gbpb9995e); however:
Package php8.0-common is not configured yet.

dpkg: error processing package php8.0-mbstring (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-core:
xserver-xorg-core depends on xserver-common (>= 2:1.20.11-1+rpt1+deb11u2); however:
Package xserver-common is not configured yet.

dpkg: error processing package xserver-xorg-core (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-video-radeon:
xserver-xorg-video-radeon depends on xorg-video-abi-24; however:
Package xorg-video-abi-24 is not installed.
Package xserver-xorg-core which provides xorg-video-abi-24 is not configured yet.
xserver-xorg-video-radeon depends on xserver-xorg-core (>= 2:1.18.99.901); however:
Package xserver-xorg-core is not configured yet.

dpkg: error processing package xserver-xorg-video-radeon (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php8.0-readline:
php8.0-readline depends on php8.0-common (= 1:8.0.25-1+0~20221028.43+debian11~1.gbpb9995e); however:
Package php8.0-common is not configured yet.

dpkg: error processing package php8.0-readline (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php8.0-cli:
php8.0-cli depends on php8.0-common (= 1:8.0.25-1+0~20221028.43+debian11~1.gbpb9995e); however:
Package php8.0-common is not configured yet.
php8.0-cli depends on php8.0-readline; however:
Package php8.0-readline is not configured yet.

dpkg: error processing package php8.0-cli (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxt6:arm64:
libxt6:arm64 depends on libice6 (>= 1:1.0.0); however:
Package libice6:arm64 is not configured yet.

dpkg: error processing package libxt6:arm64 (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php8.0-opcache:
php8.0-opcache depends on php8.0-common (= 1:8.0.25-1+0~20221028.43+debian11~1.gbpb9995e); however:
Package php8.0-common is not configured yet.

dpkg: error processing package php8.0-opcache (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsm6:arm64:
libsm6:arm64 depends on libice6 (>= 1:1.0.0); however:
Package libice6:arm64 is not configured yet.

dpkg: error processing package libsm6:arm64 (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxmu6:arm64:
libxmu6:arm64 depends on libxt6; however:
Package libxt6:arm64 is not configured yet.

dpkg: error processing package libxmu6:arm64 (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of x11-xkb-utils:
x11-xkb-utils depends on libxt6; however:
Package libxt6:arm64 is not configured yet.

dpkg: error processing package x11-xkb-utils (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxaw7:arm64:
libxaw7:arm64 depends on libxmu6; however:
Package libxmu6:arm64 is not configured yet.
libxaw7:arm64 depends on libxt6; however:
Package libxt6:arm64 is not configured yet.

dpkg: error processing package libxaw7:arm64 (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
php7.4-common
php7.4-curl
php7.4-mysql
php7.4-fpm
x11-common
php7.4-readline
php7.4-mbstring
php7.4-cli
xfonts-utils
php7.4-intl
xfonts-base
xfonts-encodings
php8.0-common
php7.4-ldap
php7.4-opcache
xserver-common
php7.4-gd
libice6:arm64
php7.4-json
php7.4-xml
php8.0-xml
php8.0-mbstring
xserver-xorg-core
xserver-xorg-video-radeon
php8.0-readline
php8.0-cli
libxt6:arm64
php8.0-opcache
libsm6:arm64
libxmu6:arm64
x11-xkb-utils
libxaw7:arm64"

Further help is greatly appreciated,
Rastko

Please share the full log as you did on your first post.

In this case I think I cant because the failed install ends just with the above mentioned error message. There is no log, also when I ran the 2 commands mentioned in the error message.

Do you think that the problem lies on my raspberry pi, YunoHost OS or router settings. OR do you think that the problem is on the YH side? Should I start again with flashing a new image or this wont help?

There is no message like Error: The operation 'Install the 'wordpress' app' could not be completed. Please share the full log of this operation using the command 'yunohost log share 20221115-184927-app_install-wordpress' to get help or a corresponding log entry in the webadmin?