Wordpress cannot upgrade


#1

Hi

I am trying yunohost for the first time, and I’m encountering a big issue straight away. I’d really appreciate some help. Currently running:
“yunohost”: {
“repo”: “stable”,
“version”: “3.4.2.3”

When I install Wordpress, I immediately get the error that automatic wordpress updating has failed. When I try to do it manually, it hangs on unpacking files. I tried installing wordpress manually in a custom Webapp, but then when I try to restore my old hosting provider’s backup using All in One WP Migration it hangs on 100%, not actually doing anything. Checking the folders using SFTP reveals that nothing is actually uploaded.

According to wordpress, the max filesize is 1GB, and the backup is 200MB. I tried uploading a file manually, since I suspect that there is some kind of PHP or nginx configuration error, but the moment I press upload I get 413 Request Entity Too Large. I still can’t upgrade. I’ve modified a bunch of PHP and ngnix config files by hand to increase max upload size and memory size but to no avail.

I appreciate your help,
Bram


#2

Hello bramkoert,

Just tried to install the current version. I have indeed an error of the automatic upgrade, and a manual upgrade seems to hang forever…
No errors in nginx log.
Looks like there’s an internal error in wordpress about migrating from 4.9.1 to 5.0.3…
Can’t find any information about that…

An upgrade for the package to install the version 5.0.3 is ongoing, https://github.com/YunoHost-Apps/wordpress_ynh/pull/55
Just need reviews from @Apps group.