[Wordpress] Augmenter la taille maximale des fichiers d'upload

Mon serveur YunoHost

Matériel: : Olinuxino LIME 1
Version de YunoHost: 3.5.2.2
J’ai accès à mon serveur : Complet
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

Bonjour,

J’aimerais uploader des images sur mon instance wordpress, mais la limite de 1 Mo est très insuffisante. Comment est-ce que je peux l’augmenter ?

Logiquement la limite est de 30M

Est-ce que c’est installé avec mywebapp ?

c.f. https://www.tecmint.com/limit-file-upload-size-in-nginx/

By default, Nginx has a limit of 1MB on file uploads. To set file upload size, you can use the client_max_body_size directive

Edit : my bad, y’a bien la ligne dans la conf nginx aussi :


La ligne client_max_body_size ne se trouve pas dans le fichier. Je dois la créer ?

Pourquoi ne pas mettre à jour l’app ? Le fichier de conf nginx a peut être été modifié à la main ? En même temps il me semble que logiquement le changement est appliqué et l’utilisateur est préveu qu’il doit réappliquer manuellement ses changements.

L’app est déjà à jour et je n’ai pas touché au fichier de conf.

Tu n’a pas répondu à ma question.

Connais tu le numéro de version du package de ton app ? Quand tu dis l’app est déjà à jour, comment le sais tu ?

La version du wordpress est 5.2.
Je n’ai pas eu besoin de my_webapp, il y a déjà une appli officielle Wordpress.
Je sais qu’elle est à jour, c’est la commande yunohost app update qui me l’a dit.

Que donne

cat /etc/yunohost/apps/wordpress/settings.json
ls /var/wordpress

«Aucun fichier ou dossier de ce type»

Pour les 2 ?

Pour la 2ème commande c’est plutôt

ls /var/www/wordpress

Et du coup je souhaite voir:

ls /etc/yunohost/apps
ls /etc/yunohost/apps/wordpress

Oui, pour les 2.
Pour les commandes qui suivent:

index.php        wp-admin              wp-cron.php        wp-settings.php
license.txt      wp-blog-header.php    wp-includes        wp-signup.php
php.ini          wp-comments-post.php  wp-links-opml.php  wp-snapshots
readme.html      wp-config.php         wp-load.php        wp-trackback.php
robots.txt       wp-config-sample.php  wp-login.php       xmlrpc.php
wp-activate.php  wp-content            wp-mail.php


doctorcube       hotspot   mumbleserver  nextcloud    searx      wordpress
etherpad_mypads  jirafeau  my_webapp     opensondage  synapse    zerobin
freshrss         keeweb    my_webapp__2  piwigo       ttrss
hextris          lutim     netdata       rainloop     vpnclient

conf manifest.json scripts settings.yml status.json

I have found that I need to modify at the very end of

sudo nano /etc/php/7.3/fpm/pool.d/wordpress.conf

these three value

php_admin_value[upload_max_filesize] = 50M
php_admin_value[memory_limit] = 64M
php_admin_value[post_max_size] = 50M
1 Like