WIKIjs and gateway error 502

My YunoHost server

Hardware: DIY PC based on ASUS H110M motherboard,INTEL Core i3
CPU, 8GB RAM
YunoHost version: 4.3.62
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

Second update same error. My previous post has been closed since there was no answer.
When updating Wikijs from (wikijs) from 2.5.219~ynh2 to 2.5.274~ynh1 and running the app I get a Gateway error 502 …nginx
I then Uninstalled ver. 2.5.274 and restored pre-update backup and everything works again.
Just for developer info that the upgrade does not work!
Thanks if you can help, but I will hold on to ver.219 until new version is upgradeable. I have a software guide running and cannot allow a complete crash of the wiki.

What would be useful to dig the issue is to go in the “Services” section of the webadmin where you should see that the corresponding wikijs service is down (maybe). In any case, sharing the logs of the service (using the green ‘Share with yunopaste’) button may bring some insight

Here are the logs.https://paste.yunohost.org/agukefenob

Thanks for your help with this issue @Aleks

Uh wokay but it sounds like this is nginx’s logs and not wikijs logs …

Sorry @Aleks here they go

https://paste.yunohost.org/zowojituli

Bonjour,

J’ai également la même anomalie lorsque j’ai fais la mise à jour de WikiJS.

Les logs du service retournent ceci : hastebin

Je ne sais pas si c’est lié à l’anomalie de Vanitarium.

Pouvez-vous m’indiquer ce qui ne va pas ?

Merci par avance.

I’m facing the same issue. Investigate a bit further tend to incriminate the systemd service that have been a bit to hardened.
In my case, commenting the line :

RestrictAddressFamilies=AF_UNIX AF_INET AF_INET6

in the file /etc/systemd/system/wikijs.service fixed the error.

Can you try with AF_NETLINK like that :
RestrictAddressFamilies=AF_UNIX AF_INET AF_INET6 AF_NETLINK
I had a similar issue with Glitch-Soc and Mastodon package.

Merci and thank you! I shall try the solution given by @oiseauroch and report back when done…
Why are you trying with AF_NETLINK @Tagada ??
I really do not know enough about what you guys are doing , sorry to be ignorant…

I had a similar issue while hardening the systemd service with the Glitchsoc package, and found that AF_NETLINK was needed for it to work.
The solution given by @oiseauroch make me think we miss the same parameter here too.
Plus there’s a PR pending that add AF_NETLINK in the example package template.

It works ! good job. I’m not used for systemd security so that I did’nt investigate further :smile:

1 Like

Done what @Tagada suggested and it works fine.
I shall mark it as solution!!
Thank you @Tagada

1 Like

Hello,
For me, @oiseauroch’s solution works perfectly (comment line), but not @Tagada’s (replace line).
Therefore, I keep the comment on the comment line.

Thanks a lot for your help !!!

Sorry, i wrote a mistake, it’s not working for me whatever the solution …

I share my log after @Tagada modification.
https://paste.yunohost.org/ugihinahux

Thank you for your help !

This is not the same error, and I think it’s not related to the previous one.
Can you try to force an upgrade ?
sudo yunohost app upgrade wikijs -F

Woah ! Now it’s running perfectly !!

Thank you !!

1 Like

Now the same error with Mattermost update too… what is going on with yunohost??? @Aleks ?

Here are the logs for this disaster

https://paste.yunohost.org/ukumobagos

@Aleks please help: my updates are failing due to some hardening of something by yunohost developers!!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.