(Was) Locked out of my server after restore

My YunoHost server

Hardware: VPS bought online (PulseHeberg)
YunoHost version: 11.1.20
I have access to my server : through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : maybe? :grimacing:
If yes, please explain: The ssh connection port has been changed to 6789

Description of my issue

Hello!

This message is maybe a bit weird, because as I posted it, the problem resolved itself. I’m still posting, because maybe someone will have an explanation.

I have a Yunohost server on a VPS hosted by OVH. Now I’m moving out to another provider. I logged in in ssh on this new server, did the curl | bash thing, all clear.

Now, as I have an export of my current server, I sent it through ftp, and launched the restore action: yunohost backup restore <my_archive_name>. All is well, a bit… long but hey, not complaining here.

The problem is afterwards: I can’t login via ssh anymore. I have a timeout, even before asking for my password. I use the new port, and the admin user of the current server (“lara”). Like this: ssh -p 6789 lara@server-IP. Nothing, just a timeout.

The first time, I wiped the new server and started over. The second time, I kept a terminal window open, and the server rebooted because I tried the VNC window on my provider webpage and clicked on the “Ctrl+Alt+Del” button (yeah, I know, the joke’s on me, never click on unknown buttons). So I ragequitted.

And now I’m trying again. As I was writing, I retried to login, in order to have the exact error message to show you. And it worked. No password needed because I had a private/public key pair on the current server, which was copied in the export I guess.

So: it works. And I don’t know why. I’m a bit nervous, nevertheless. Did it happen to somebody else, who could explain?

Thank you, and long live Yunohost!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.