Warning message: "Failed to resolve A for hostname-overleaf.nohost.me"

My YunoHost server

Hardware: RPi 3B+
YunoHost version:
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Few weeks ago, I tryied installing the Overleaf app but, as I run a armh hardware, this app cannot run on my server. During the Overleaf installation, a dedicated domain was asked to be created, and I chose “hostname-overleaf.nohost.me”.

As it was not running, I removed the app, but since then I receive warning e-mail messages with the following:

  • Subject: “Cron root@hostname : YunoHost DynDNS update; sleep $((RANDOM%60)); ! ping -q -W5 -c1 ip.yunohost.org >/dev/null 2>&1 || test -e /var/run/moulinette_yunohost.lock || yunohost dyndns update >> /dev/null”
  • Body: “Failed to resolve A for hostname-overleaf.nohost.me”.

Any idea how I could fix that?

Hello !

Do you still have your domain listed in yunohost ?
sudo yunohost domain list
if yes, and you don’t want to use it anymore, you can remove it with :
sudo yunohost domain remove hostname-overleaf.nohost.me

Hope it helps, if I understood your problem correctly.

No, after removing the App I removed the domain using the Admin page.
(only my regular domain is listed when running sudo yunohost domain list)


$ sudo yunohost domain remove hostname-overleaf.nohost.me
Error: Domain 'hostname-overleaf.nohost.me' unknown

I think the point is that the installation of overleaf triggered the creation of a check to verify that the domain that you chose for overleaf is in working order.

When removing overleaf, maybe some bits stayed installed, among which this check to verify that the domain for (the now not anymore installed) overleaf is available.

In this case, more specific: it seems a check to update the noho.st record for your domain in case your IP changed.

How often do you receive this email? You could then have a look in /etc/cron.[daily|weekly]/...

I don’t have any noho.st (etc.) domains, so I’m not quite sure which script to check.

The automated e-mail subject is exaclty what I can find in /etc/cron.d/yunohost-dyndns

/etc$ more cron.d/yunohost-dyndns                                                                                                                                                                     
# Every 10 minutes,                                                                                                                                                                                               
#   - (sleep random 60 is here to spread requests over a 1-min window)                                                                                                                                            
#   - if ip.yunohost.org answers ping (basic check to validate that we're connected to the internet and yunohost infra aint down)                                                                                 
#   - and if lock ain't already taken by another command                                                                                                                                                          
#   - trigger yunohost dyndns update                                                                                                                                                                              
*/10 * * * * root : YunoHost DynDNS update; sleep $((RANDOM\%60)); ! ping -q -W5 -c1 ip.yunohost.org >/dev/null 2>&1 || test -e /var/run/moulinette_yunohost.lock || yunohost dyndns update >> /dev/null


I tried the command in the cron-line:

# yunohost dyndns -?
usage: yunohost dyndns {subscribe,update,installcron,removecron} ... [-h]
yunohost dyndns: error: the following arguments are required: {subscribe,update,installcron,removecron}
# yunohost dyndns update
Error: No domain registered with DynDNS

I would guess it feeds the list of domains from yunohost domain list for the updates. You already told that the hostname-overleaf-domain is not visible under domains. Does it show with the domain list command?

Using the subscribe option, I got an error that my main domain (probably default when not giving a domain) is not eligible for dynamic DNS.

I also tried

$ sudo yunohost dyndns removecron
Warning: 'yunohost dyndns removecron' is deprecated and will be removed in the future
Warning: 'yunohost dyndns removecron' is deprecated and will be removed in the future
Warning: This command is deprecated. The dyndns cron job should automatically be added/removed by the regenconf depending if there's a private key in /etc/yunohost/dyndns. You can run the regenconf yourself with 'yunohost tools regen-conf yunohost'.

Will you try running the suggested regen-conf?

$ sudo yunohost tools regen-conf yunohost

Thanks for the suggestion. I have run the above command. No feedback. Will wait some time to see if more cron warning e-mails are still arriving…

Not fixed. One e-mail from cron this night.


Would you try adding the domain again?

  • If the domain is still hanging around in the configuration, it should give an error. That might give an idea where to look for the cause
  • If it gets overwritten and added successfully, there should be no notification tonight. Then remove the domain again tomorrow, and see whether the notifications stop.

Then of course there is the ongoing thread about removing yunoho.st, noho.st and ynh.fr, any chance your domain needs to be removed/added/xxx via that way?

No, it’s a global problem, see this thread. No solution yet.


Actually, I uninstalled Overleaf as this app cannot run on my hardware. So, I will not add that domain again (it was a domain dedicated to the Overleaf app). My main domain is running fine, hosting all my other apps.

The automatic diagnosis states:

Internet connectivity (ip)

[WARNING] DNS resolution seems to be working, but it looks like you're using a custom /etc/resolv.conf.
  - The file /etc/resolv.conf should be a symlink to /etc/resolvconf/run/resolv.conf itself pointing to (dnsmasq). If you want to manually configure DNS resolvers, please edit /etc/resolv.dnsmasq.conf.

Did anyone manage to solve that problem ? I still keep receiving those (twice) daily emails…

Always those cron emails also on my server.

I noticed that the service yunomdns failed to run:

On my side, no problem with the yunomdns service. But I’m still receiving the daily emails (except for the 15th and 16th of October: did someone play with some settings on that day ?)

BTW, from time to time, I get a slightly different message:

Failed to resolve AAAA for blablabla.nohost.me

I started receiving similar messages on October 3rd:

Subject: Cron root@XXX : YunoHost DynDNS update; sleep $((RANDOM%60)); ! ping -q -W5 -c1 ip.yunohost.org >/dev/null 2>&1 || test -e /var/run/moulinette_yunohost.lock || yunohost dyndns update >> /dev/null

Body: Failed to resolve A for XXX.nohost.me

I hadn’t made any adjustments to my server since September 2nd. Everything seems to be working fine I just have no idea what these messages mean.

Hi this has a lot to do with DynDns being made commercial and away from open source by USA corporation

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.