Wallabag v2 - intégration dans yunohost?

,

Eu… je comprends pas tout là ^^

Je teste d’ici peu :wink:

En d’autres mots, si vous avez installé Wallabag v2, il vous faudra d’abord désinstaller l’application avant d’aller plus loin : il y a eu plusieurs changements qui feront que la mise à jour ne fonctionnera pas. Cependant, avec ces nouveaux changements, la mise à jour est désormais implémentée. Vous n’aurez donc plus à désinstaller l’application, la commande suivante devrait fonctionner : sudo yunohost app upgrade -u https://github.com/YunoHost-Apps/wallabag2_ynh wallabag2.

C’est plus clair ? :slight_smile:

Ah ok, mise à jour depuis la v2 de wallabag, et non la v1.
Tu confirme que l’installation simultanée des v1 et 2 est possible ? (ça simplifierai mes tests).

Au final j’ai simplement exporté depuis la v1, et récupéré l’export. Tout roule, merci pour ce portage ! :wink:

Oui, pas de problème.

Je viens de m’apercevoir que je n’avais pas donné de nouvelle :sweat_smile:

Et ben j’ai installé la v2, importé le .json de la v1, tout a fonctionné - seul problème, des tags se sont dupliqués, mais ça semble être un bug connu.

Merci pour ton travail ! :slight_smile:

I see error message on Starred ,Archived , unread and while importing the json file from the previous version.

Oops! An Error Occurred
The server returned a "500 Internal Server Error".
Something is broken. Please let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused.

Bonjour a tous
Merci pour ce package !
J’ai le même problème avec ce message:
`` Oops! An Error Occurred```
The server returned a “500 Internal Server Error”.
Something is broken. Please let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused.`

C’est assez aléatoire sur différentes pages amis plutôt sur “All” , je précise que je suis sur une install fraîche et clean :wink:
Si quelqu’un a une idée…

J’ai exactement le même problème que thomas, “500 internal server error” après une installation fraiche. Ça marche quand je cré un nouveau utilisateur, mais j’aimerais bien d’éviter de faire un nouveau login á caque fois que je veux utiliser Wallabag.

Quelqu’un a des news sur une éventuelle mise à jour du package ou la résolution du problème ?
En attendant retour sur la V1 :frowning:

Alors j’ai trouvé la cause des erreurs 500 pour mon cas je ne sais pas si c’est valable pour tous les autres.
Dans mon log de nginx j’avais ça:
[error] 6948#0: *687012 FastCGI sent in stderr: "PHP message: PHP Fatal error: Call to a member function getItemsPerPage() on null in /var/www/wallabag2/src/Wallabag/CoreBundle/Controller/EntryController.php on line 262" while reading response header from upstream

A force de Google je suis tombé ici: http://support.wallabag.org/discussions/problems/476-error-while-trying-to-display-ex-alllist-or-add-articles-on-a-new-wallabag-202-instance

J’ai donc été dans Config --> Settings --> Item per page et j’ai fixé un nombre (20 pour moi) et tout fonctionne (pour l’instant) !!

Prochaine étape l’appli Android et le bookmarklet !

2 Likes

merci @thomas, ta solution a aussi fonctionné pour mon problème

@Bachy Content d’avoir pu aider ! :slight_smile:

Depuis la dernière version plus moyen d’utiliser l’extension Firefox (a cause de SSO ?) et le bookmarklet (erreur 500) c’est dommage parce que globalement elle marche vraiment mieux ! Si quelqu’un à des idées ?
Pour le bookmarklet j’ai ça dans les logs nginx :
rewrite or internal redirection cycle while redirect to named location "@wallbag2"

Depuis la dernière mise à jour de l’app ?
Je viens de me rendre compte du problème, en effet ça coïncide avec ma mise à jour.

T’as aussi un message d’erreur par rapport aux annotations ?

Elle est même compatible avec Electrolytis (pour Firefox) :slight_smile:

Pour l’extension FF impossible de trouver une ligne qui correspond dans les logs et si je regarde le débug de l’extension dans mon FF j’ai juste “login/mot de passe incorrect” alors que c’est bien le bon (merci Keepass :slight_smile: )
Sinon pour le bookmarklet qui est mon principal outil pour wallabag je trouve dans nginx par exemple:
2016/11/29 21:58:18 [error] 4177#0: *1082558 rewrite or internal redirection cycle while redirect to named location "@wallbag2", client: 92.171.104.151, server: domaine.tld, request: "GET /wallabag/bookmarklet?url=https://linuxfr.org/users/rodhlann/journaux/des-basheries HTTP/1.1", host: "domaine.tld", referrer: "https://linuxfr.org/users/rodhlann/journaux/des-basheries"

Edit: ça ne me gêne pas mais l’erreur 500 est aussi présente si tu veux faire un export

Hum oui c’est embêtant tout ça… M’apprendra à ne pas tester la totalité de l’app avant de dire au mainteneur que ça fonctionne correctement :confused:
Tu peux lui faire un rapport de bug (vu que t’as déjà les logs), ou je m’en charge ?

C’est fait :wink:

https://github.com/YunoHost-Apps/wallabag2_ynh/issues/14

Et j’ai répondu :slight_smile:

J’ai mis à jour sur Github, mais la solution pour le bookmarklet est d’éditer /etc/nginx/domain.tld.d/wallabag2.conf
et dans location @wallbag2 remplacer:
rewrite ^ /wallabag/app.php$is_args$args;
par:
rewrite ^ /wallabag/app.php?is_args$args;

A priori cela ne casse rien d’autre et résoud aussi le problème avec l’export.

Le problème est toujours présent avec l’extension pour FF par contre.

1 Like