Wallabag Android App

Hey there! As my French is too bad to follow the conversation about the wallabag android app maybe here is the better place …will there be a update so anyone can use the wallabag android? it looks like there is a solution but only if you change code by yourself…


No idea anyone? Thought it would change with the latest ssowat…but it didn’t…

hey @mr_smithers you dont need to change code,you just need open the terminal and copy past that 3 lines.check the other thread,its the best solution for now,and is working with me:)
and is working with the last updates.

dont forget after the 3 lines
sudo yunohost app ssowatconf

Thanks for the reply…
I think i don’t want to change anything within the terminal, ill wait till its “official” :smile:

Could you please provide some instructions in English on how to solve this?

What are the three lines that need to be paste and are those lines to by put in a file?

Thank you!

never mind, I found the english instructions on the other post.


I have an interesting issues with wallabag in relation to the fix that was provided here and on the French page that I am not able to solve.

I have 3 domains in my yunohost as below example:

default domain: yunohost.mydomain.com
other domain: owncloud.mydomain.com
other domain: wallabag.mydomain.com

I have installed one application on each and have created Reverse Proxies on my network to map everything; all works good except the wallabag application.

before applying the below fix for correcting the sync with android everything works good

sudo yunohost app setting wallabag skipped_urls -v "wallabag.mydomain.com/wallabag"
sudo yunohost app setting wallabag unprotected_uris -v "/"
sudo yunohost app setting wallabag skipped_regex -v “^/wallabag/?(.*)feed=true”

sudo yunohost app ssowatconf

However, after applying the above fix, I can no longer login to wallabag through the web browser. It points my to the wallabag login page instead of the portal sso page. and when I enter my login credential to the wallabag login page it says that the login info are not correct.

If i remove the below setting (meaning execute the below with value “”)
sudo yunohost app setting wallabag unprotected_uris -v “/”

I am able to login through the web fine, but my android sync is not working.

So, I was hoping someone has some more imagination than me and help me figure out a way that I can have both working.

Some additional info:
Wallabag has been installed on domain wallabag.mydomain.com as stated above and it has been setup as the
Thank you in advance!

After applying the above fix,
you need to login in sso portal via browser,after, click in wallabag app ,the app opens without any login page and you need to do the same in android for share links.
if i go directly to mydomain/wallabag without login in sso portal first,appears the “login to wallabag” that is not working if i put my user and password.
i only find this way to put wallabag working,maybe someone can update to the new version of wallabag,it will be out in september the v2.0

if i nano /etc/yunohost/apps/wallabag/settings.yml
my last 4 lines are:

path: /wallabag/
skipped_regex: ^/wallabag/?(.*)feed=true
skipped_urls: pi.nohost.me/wallabag
unprotected_uris: /


You can go to wallabag config page and Drag & drop your bookmarks bar to the browser,or use extensions or mobile apps.

hope this helps :wink:

That is how I currently use it. I log in to the portal first and then I can share links from android to wallabag.

I was hopping that i could find a solution that will work without having to login to the portal first.

This line is the one that causes the issue
unprotected_uris: /
and I cannot figure out how to make it work.

May be the v2.0 will fix that, but I believe the issue may be with the sso app

Hi everyone,
does someone know if this problem has been fixed?

1 Like

Yeah, same here. Would love to get this working.

I do not understand that Wallabag makes it to the list of officially supported apps in Yunohost when it is not really ready and does not play well with the SSO of yunohost…

1 Like


Any news here if wallabag android is working ? On my side, I am unable to make it work ! If anyone has new update …

I have no problem with Wallabag2 and android app.
I’m not sure if it’s necessary, but have you set the RSS token up ?

If you have trouble running the android app, check this :

  • RSS feeds are enabled in the server config panel
  • Reinstall the android app
  • Checkout the HTTP Auth app advanced settings

Can u test a mobile-phone-tracker.org mobile recorder on Android?