VPNClient not prompting for username/password

Fresh install of Yunohost in a Proxmox LXC. Fresh install of the vpnclient application (2.1.2~ynh1)

When uploading a .ovpn generated from Windscribe (my VPN provider) and clicking “Save”, I don’t see anywhere to input my username or password (see screenshot):

From other forum posts, I see that most people have a username and password field below the .ovpn upload box. I don’t have any adblockers installed, and I’ve tried on multiple browsers.

I tried editing the .ovpn file and adding

auth-user-pass login.txt

that points to a file in the /etc/openvpn folder containing my username and password on separate lines.

Enabling the VPN results in this error, which is to be expected:

WARNING - [CRIT] You need either a client certificate, either a username, or both (you can add one through the web admin)


How do I get my username an password in here? Am I just blind?

VPNclient is mostly designed around .cube… .ovpn is sort of supported, but personnally i don’t know much about that file and i don’t know what are the expectations about the format of that file

Reading the code quickly, i can find that the credentials are parsed from /etc/openvpn/keys/credentials

Alternatively, I see that having auth-user-pass (without any file after the instruction) may enabled the ‘advanced’ section of the config panel somehow

(NB the bottom of the screenshot clearly state that 'do not expect that any VPN you randomly bought on the internet can be used)


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.