VirtualBox Kernel Panic

My YunoHost server

Hardware: Oracle VirtualBox Version 7.0.14 r161095 (Qt5.15.2)
YunoHost version: yunohost-bullseye-11.0.9-amd64-stable.iso
I have access to my server : Non at all, installation in the VM failed with Kernel Panik.
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I am trying to install the YouNoHost Image in a virtual machine. However, the installation failed with “Kernel panic - not syncing: VFS: Unable to mount root fs on unknown block(0,0)”

I am running the setup on Windows 10, Version 10.0.19045 with Hyper-V enabled. I tried to install the latest Debian image (debian-12.5.0-amd64-netinst.iso) without any problems.
Tried to remediate the problem increasing RAM, number of CPUs, use hyper-v as paravirtualization interface, increasing video memory, increasing size of virtual storage container – all to no avail.
If anyone knows a work around or fix, I would be grateful for your response.

Can you try with a Debian 11 image, then following the “remote server” method (with curl ... | bash command)?

Thank you, @tituspijean, for your suggestion. Using the latest version of Debian 11, the installation succeeded. Configuring the VM’s network adapter as ‘bridged adapter’ I can now reach the domain set in the post-configuration set, ynh.local, however applications installed into subdomains, synapse.ynh.local, are not reachable. If someone could recommend a resource to understand how domains and subdomains are resolved on a LAN (and to be configured), that would facilitate this discovery.

I’m glad the installation with that method worked for you.

You should have gotten a warning about that. .local domains cannot be subdomains. That is a limitation of the mDNS protocol, cf. our documentation.

Edit, it’s a good opportunity to check the UX about it:

  • there is no warning while entering the domain in the “I have my own domain” textbox
  • there is an error if you choose the “I want a test or local domain” textbox
  • there is a warning displayed while the configurations are generated by YunoHost: “Subdomain synapse.ynh.local cannot be handled by Bonjour/Zeroconf/mDNS”
  • this warning should also be displayed in the Diagnosis page

I created the issue to follow up with that: mDNS .local domains UX improvement · Issue #2330 · YunoHost/issues · GitHub

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.