Vaultwarden upgrade from 1.25.0~ynh2 to 1.25.2~ynh2 aborted

Hello all,
I am still a beginner here and am currently updating my YuhoHost. System upgrades went fine, and most apps updated error-free as well, except the Vaultwarden upgrade from 1.25.0~ynh2 to 1.25.2~ynh2 aborted.

My YunoHost server

Hardware: Raspberry Pi 4 8GB
YunoHost version:
I have access to my server : Both through the webadmin page and through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

When I start the Vaultwarden upgrade on the webadmin > System update page, the process aborts with this error:

Here is the full log with YunoPaste:

Thanks for you help!

It seems that the upgrade failed because the backup failed.
Maybe you can just try again ? (Maybe another backup was running ? )
Do you have enough free space ? (Vaultwarden backup in YunoHost use a huge volume of data because all source + build is backed up, not only the data)

Hi Mamie,

thanks for replying.

I have tried this update several times. I don’t think anything else was running at the same time. Here is the log of the latest attempt, I think it’s the same error:

Running df -hon the Raspberry Pi shows 11GB free on the SD card and 815GB free on the attached SSD at /dev/sda1, so I don’t think space is an issue either.

The back fails because the directory /var/www/vaultwarden does not exists. can you check that ?

Hi, thanks for replying.

I did try to update again after having created that missing directory, but it didn’t help.
I noticed the error complains about this being a missing source directory, not destination directory for the backup, so the cause of this error must be somewhere “deeper” in the installation.

Likely I’ll have to reinstall my whole YunoHost server anyway, because the migration to 11 doesn’t work (see my other issue posted at Migration fails: 21. Upgrade the system to Debian Bullseye and YunoHost 11.x). That will then also resolve this Vaultwarden update issue …

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.