Vaultwarden - Registration not allowed or user already exists

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.2.10
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: Vaultwarden Version 2023.5.0

Description of my issue

To get help efficiently, please explain what you are trying to achieve, in which context, what you tried and provide detailed error messages and logs if you can.

Hi folks, I am new here and recently started exploring the self-hosting world.

I have been able to successfully install Vaultwarden in a SSL subdomain I adjusted the SMTP settings and the email test worked fine.

When creating the first user, I get an error “Registration not allowed or user already exists”.

How do I fix this issue?

Thank you for reading this!

I have a long working Vaultwarden, and to help here I tried to create a user, and was welcomed by an error with mails.

From what I remembered, on my server I disabled registration, but enabled some domains (mine,, and I think I enabled and just during the creation of new accounts).

Maybe you should enable the domain of your mail, you can disable it later, when the account creation will be finished.

PS : It’s a pain everytime I try to create a new user.

Hi Mamie,

just to confirm. are you referring to changing the SMTP settings on the vaultwarden admin settings page? Like in the screenshot below?

Screenshot 2024-02-16 at 8.56.41 am

Quick update: I have changed the smtp setting with one of my email providers and I still get that error when I am creating the first user.

No, on my side I have a SMTP problem, I should look into it SOMEDAY™
On your side, look at the « Email domain whitelist » parameter, ant whitelist the domain of the mail you want to invite.

Here is the configuration I have :

(But I can not guarantee you that this is the solution, as I can not invite people right now)

yes, I have like 3 different domains whitelisted and it does not work. Sadly.

1 Like

Hold my beer!
The default settings do not allow for signups!
I ticked the field and I was able to create the first user.

Screenshot 2024-02-16 at 11.46.21 pm

1 Like

As I said : it’s always painfull to create accounts :grin:

Happy you found out a solution :+1:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.