Vaultwarden cannot send email after initual setup

My YunoHost server

Hardware: VPS bought online /
YunoHost version:
I have access to my server : Through SSH & through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : No

If your request is related to an app, specify its name and version: Vaultwarden 1.29.1~ynh3

Description of my issue

Hello, this is my first foray into Yunohost, and looking forward to implementing it into 2 businesses i manage all on my own. Have no professional sysadmin skills,training or certs except for 30yrs of searching internet for solutions. I now only use Linux or MacOS.

Installed Debian 11 on my VPS yesterday, then installed Yunohost, i have 100% pass results in Diagnostics (except fro IPv6 implementation). I can send and receive email using Snappymail.

I have installed Vaultwarden, and with the default configuration, it cannot send emails.
Seems must need to enable “Use Sendmail”, so done that and then get following error when sending a Test email (anything in JSON is all greek to me)


Error sending SMTP test email 504 - [Catch] SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

my configuration from the .env file is


I have tried other variations of the settings like enabling Starttls and changing port but always same error.

There is a section on Using Sendmail (withoug Docker) at the very bottom of the page. SMTP Configuration · dani-garcia/vaultwarden Wiki · GitHub
But I would assume that if such detailed changes were required this would be detailed in the Yunihost App information, as it does for many others.

ps. xxxx in my domain name = the great australian beer, not kisses.

hi and welcome ^w^

a fix has made some time ago and is currently in the testing branch, with it it should work out-of-the-box

yunohost app upgrade vaultwarden -u

can you tell me if it works after that?


thanks for the info! I installed that version using the method you suggested, but it remains the same version number 1.29.1~ynh3 that i already installed (and the install script indicated that too in not so many words) . so no change to the issue.

I am not familiar with Github terminologies, how can i tell which is the version number that solved this bug?

hum yeah, you need to add --force at the end if the version number doesn’t change, sorry for that

yunohost app upgrade vaultwarden -u --force

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.