Vaultwarden - 502 Bad Gateway after update to 1.23.0~ynh2

Hello, all!

I’ve been using YunoHost for a few months now and I think it’s fantastic!

My YunoHost server

Hardware: Running as a VM in VirtualBox on a 2012 Mac Mini. Assigned 8GB of RAM and a single processor.
YunoHost version:
I have access to my server : Through SSH and webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : No

Description of my issue

I ran into a problem when I updated the server and apps this morning, a Vaultwarden issue where I’m getting a bad gateway error. According to diagnostics, the Vaultwarden service fails to start. I tried restarting it manually, and get the following error in my log:

  • Jan 24 05:12:14 vaultwarden[6763]: [INFO] No .env file found.
  • Jan 24 05:12:14 systemd[1]: vaultwarden.service: Main process exited, code=exited, status=1/FAILURE
  • Jan 24 05:12:14 systemd[1]: vaultwarden.service: Failed with result ‘exit-code’.

I checked, and yes, there’s a .env file in /var/www/vaultwarden/live, and it looks correct. Vaultwarden was working properly before the update.

Worse comes to worst, I can roll back to a previous VM and update only the system files. Vaultwarden was the only app on the server that needed an update.

Thanks so much!


There is a PR to fix this issue. It should be merged soon and released soon I think. Fix datadir by Tagadda · Pull Request #165 · YunoHost-Apps/vaultwarden_ynh · GitHub If you want you can restore the pre-upgrade backup of the app.

1 Like

Superb! Thanks for the info!

1 Like

Thank you very much, works for me

1 Like

Follow up: I was able to update to the new version of Vaultwarden this morning and, after the update completed, I was able to log in and use the app. Looks like things are back up and running!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.