Using ttyd/wetty with publickey auth

My YunoHost server

Hardware: Laptop at my home
YunoHost version: 11.2.5
I have access to my server : Directly
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : Somewhat?
If yes, please explain: Password authentication is off
If your request is related to an app, specify its name and version: httpsh on ttyd, 1.7.3~ynh1

Description of my issue

I’m attempting to set up a web shell to be able to work on some of my projects while I’m away from home. All of the web shell applications seem to rely on sshing to localhost though, and mostly don’t offer publickey options. I turned ssh password auth off for various reasons.

Is there a way I can set this app up to just drop me into a shell? It’s locked behind the admin usergroup in ynh anyway so I don’t think it’s an issue.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.