Url conflict with Wireguard - unable to install an application

On vps KVM
This message appears every time I try to install an application
Url not available or in conflict with ==> Wireguard (1st only application)

Hello, if you need help please use the template for asking for support.
We are missing information here to help you.

Rules for help topics : Asking for support / Demander de l'aide

how are you trying to install (CLI / web) ? Which app ? is it on another domain / subdomain ?
we cannot help you without a minimum insight. Please provide logs if possible.

I tested both web & CLI for the same result
No log files exist except the one from wireguard
Log files were not created for failed installations
I have tested several application installations with the same result


I suppose Wireguard is the first application you’ve installed on your YunoHost instance and i think Wireguard need to be the only one application installed on a domain.

So, for example, if you have a YunoHost domain’s name like whateveryouwant.nohost.me you should first add a new sub-domain for Wireguard in the web panel of your YunoHost instance as wireguard.whateveryouwant.nohost.me or vpn.whateveryouwant.nohost.me.

Edit : https://yunohost.org/en/dns_nohost_me


Thank you for the answer
Indeed it is the first installation on the domain.

Is it sure that wireguard is the only installation allowed on the root of the domain?

Because finally it is not specified during the installation of the application.
So finally I create a sub-domain the problem should be solved.

What can cause this prohibition to install wireguard next to other conventional applications?
Strange, isn’t it?


In most cases, applications are installed “as in a folder” :

But in some cases for technical reasons that i can’t explain some applications need a (sub)domain to be installed :


This is unrelated to WireGuard’s UI itself, but rather to how apps “reserve” URLs in YunoHost.

If an app is installed at the root of a domain, then no other application can be installed on it, because the server would gave no way to know which paths are actually needed by the app.

As ppr said, sometimes we have no choice regarding app location. WireGuard’s UI contains hardcoded links that forces us allot it a whole domain. :slight_smile:

We should however find a way to warn users that they need to create a dedicated domain during install.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.