Uploading a WordPress site

My YunoHost server

Hardware: VPS bought online / Old laptop or computer / Raspberry Pi at home / Internet Cube with VPN / Other ARM board / …
YunoHost version: 4.2.8.3
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

I have several websites using WordPress, I have found the location /var/www/wordpress_xx where they all live

I am logged in using SFTP as admin

What I have is another WordPress website to import into a new YNH wordpress app.

If I try to upload the files and folders to the newly created app space I get permission denied.
Can anyone help me with this, please?

I have the domain
Installed the WordPress app
Logged in as admin using FileZilla
I can see my server etc
Navigated to /var/www/wordpress_5
Tried to delete all the content so I can upload my new one (Permission denied)
Tried to just go ahead and upload the new site (Permission denied)

I remember, I might be wrong, that even admins can’t modify folder/files using SFTP or am I wrong? Again!

Any help to get my old site into my YHN server is appricated

Thanks

dj

Hi,

I don’t have a complete plan for you, only some remarks that might help you on your way.

  • First, copy files to /home/admin/wordpress_temp/ (or another name for temporarily parking the files
    Reason: admin is indeed not allowed to ‘just write’ everywhere.
  • Then log in to you Yunohost using SSH as admin
  • Once logged in, use sudo before the copy command. That should enable you to copy into /var/www/wordpress… directories:
    cp /home/admin/wordpress_temp /var/www/wordpress__5
  • Your files are now available. You didn’t mention problems with the database. Did you already solve that, or is that up next? If not yet done, installing phpmyadmin on your Yunohost will be helpful!

Good luck :slight_smile:

@wbk thanks for this.

I will give that a try, didn’t think of using a temp directory so I’ll give that a go.

DB is sorted I. think. I installed phpmyadmin and imported the DB in so all good there I hope.

Thanks so much for your help.

dj

1 Like