Upload of files not working

Hi there,

I have a small problem with my Overleaf install.

My YunoHost server

Hardware: VPS bought online
Yunohost Version: 11.1.20 (stable)
Overleaf Version: 2022.04.23~ynh1

I have access through SSH and webadmin

I am not in a special context and did not do any particular tweaking. I did though install Overleaf through the command line via ssh after an install through the webadmin failed and I had to reboot the machine to get access again. I uninstalled through webadmin and then proceeded to use the ssh command line, to eventually see futher error messages, but all seems to have installed well.

Description of my issue

Basically the issue is about uploading files I want to use with Overleaf projects, e.g. JPgs and the like.

First I did was create the Example project. I got an error about it having failed, only to see the project in my project list later. I proceeded to compie the project and a pdf was created, but also I got an error message in the logs pointing to line 46 where the frog.jpg file is integrated into the document. Problm being: The frog.jpg file does not exist.

So I proceeded to create a frog.jpg and tried to upload it. This doesn’t work: The ADD File modal window says “Sorry, something went wrong” and for a few seconds a message saying “Failed to upload frog.jpg”.

I tried to upload other files afterwards, also plain text files, but the error persists. This is also true for empty projects I created and tried to upload files to.

I am not sure wether the error message I got upon creation of the example project is related, but I thought I mention it in case this gives a hint.

Hope this explanation is verbose enough to allow for help.

Thanks for all your effort.


Same here :woozy_face:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.