Upgrading Nextcloud from 25.0.4 to 27.1.2 fails

My YunoHost server

Hardware: VPS bought online - Linode/Akamai
YunoHost version: 11.2.4
I have access to my server : Through SSH & through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: nextcloud v25.0.4~ynh1

Description of my issue

Hello everyone,

Attempting to upgrade Nextcloud from 25.0.4~ynh1 to 27.1.2~ynh1, it seems to fail due to an incompatibility with PHP>=v8.2. I have 8.2.11, but also four previous versions back to v7.4. My ignorance of PHP leaves me at a loss here. I also tried the testing branch, failing with the same error.

Here is my error log: https://paste.yunohost.org/raw/uxosucufop

Any ideas? Thanks a lot for your help!

1 Like

Hello everyone,

seems like the same error with my YunoHost:
Could not upgrade nextcloud: An error occurred inside the app upgrade script:
Nextcloud von 25.0.6~ynh1 nach 27.1.2~ynh2,
YunoHost 11.2.5 (stable) on a RPI4
Error Log: https://paste.yunohost.org/raw/worudumova

From what I understand by googling: The Nextcloud installer doesn’t like PHP> v8.2., PHP 8.2.11 seems to be installed by the YunoHost update script.
It should work if at first a PHP >= 8.2 is installed, then the Nextcloud upgrade, then the PHP upgrade.
Or maybe change the install script?

Thanks for any help!

1 Like

I too am unable to upgrade Nextcloud (from 25.0.6~ynh1 to 27.1.2~ynh2).
I get “Could not upgrade nextcloud: An error occurred inside the app upgrade script”.


Bought VPS
YunoHost 11.2.5



also the update Nextcloud (nextcloud) from 25.0.6~ynh1 to 27.1.2~ynh3 fails on my Raspberry Pi 4.
See log:
Maybe it fails because of this:
DEBUG - This version of Nextcloud is not compatible with PHP>=8.2.
You are currently running 8.2.12.+ ynh_exit_properly

Any ideas?

1 Like

I am also having this problem. Is there a way to downgrade the PHP Version to 8.1?

I found a fix :slight_smile: For all still having the problem: First upgrading to Nextcloud 26 and then to 27 fixes the problem.
You just need to execute the command in this github thread to upgrade to Nextcloud 26: Upgrade failed due to PHP version not compatible · Issue #617 · YunoHost-Apps/nextcloud_ynh · GitHub

Afterwards the normal upgrade to Nextcloud 27 works.

sudo yunohost app upgrade nextcloud -u https://github.com/YunoHost-Apps/nextcloud_ynh/tree/oldstable

Thank you! That worked for me.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.