Upgrade to Debian 11 failing : Raspberry Pi 3B+ / dh-autoreconf python3-gi issues

I’m trying to upgrade to Debian/Yunohost 11.

It fails with this error.

edit: this is a raspberry pi 3B+.

Info : + Les paquets suivants contiennent des dépendances non satisfaites :
Info : + debhelper : Dépend: dh-autoreconf (>= 17~) mais ne sera pas installé
Info : + libgirepository-1.0-1 : Casse: python3-gi (< 3.34.0-4~) mais 3.30.4-1 devra être installé

Removing those packages is impossible as dh-autoreconf removal will remove Yunohost package.

What can I do ?

Can you please share the full log otherwise we don’t know the exact context of when the failure happens and this makes it impossible to properly debug …

I can’t share the original one : I restored a backup.

Here is an extract (I still have the console open): yunohost tools migrations run migrate_to_bullseye --accept-disclaimerInfo : Ex - Pastebin.com

So I’m thinking the issue has to do with some sort of graphical environment

Maybe you can try to see what would happen with apt remove python3-gi libgirepository-1.0-1 --dry-run

Indeed it is (partly ?) installed by error, I did not take the time to remove it.

Les paquets suivants seront ENLEVÉS :
  alacarte gir1.2-atk-1.0 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-glib-2.0 gir1.2-gmenu-3.0 gir1.2-gtk-3.0 gir1.2-notify-0.7
  gir1.2-packagekitglib-1.0 gir1.2-pango-1.0 gir1.2-polkit-1.0 gir1.2-secret-1 hplip libgirepository-1.0-1 python-gi python3-gi
  python3-gi-cairo sense-emu-tools system-config-printer system-config-printer-common
0 mis à jour, 0 nouvellement installés, 20 à enlever et 0 non mis à jour.
Remv alacarte [3.11.91-4+rpt2]
Remv system-config-printer [1.5.11-4]
Remv system-config-printer-common [1.5.11-4]
Remv gir1.2-gtk-3.0 [3.24.5-1+rpt2]
Remv gir1.2-atk-1.0 [2.30.0-2]
Remv gir1.2-pango-1.0 [1.42.4-8~deb10u1]
Remv gir1.2-freedesktop [1.58.3-2]
Remv gir1.2-notify-0.7 [0.7.7-4]
Remv gir1.2-gdkpixbuf-2.0 [2.38.1+dfsg-1]
Remv gir1.2-polkit-1.0 [0.105-25+rpt1+deb10u1]
Remv sense-emu-tools [1.2-1]
Remv python3-gi [3.30.4-1] [python3-gi-cairo:armhf hplip:armhf ]
Remv gir1.2-glib-2.0 [1.58.3-2] [gir1.2-gmenu-3.0:armhf gir1.2-secret-1:armhf python-gi:armhf python3-gi-cairo:armhf hplip:armhf gir1.2-packagekitglib-1.0:armhf ]
Remv gir1.2-gmenu-3.0 [3.31.4-3] [gir1.2-secret-1:armhf python-gi:armhf python3-gi-cairo:armhf hplip:armhf gir1.2-packagekitglib-1.0:armhf ]
Remv gir1.2-packagekitglib-1.0 [1.1.12-5] [gir1.2-secret-1:armhf python-gi:armhf python3-gi-cairo:armhf hplip:armhf ]
Remv gir1.2-secret-1 [0.18.7-1] [python-gi:armhf python3-gi-cairo:armhf hplip:armhf ]
Remv hplip [3.18.12+dfsg0-2+b2] [python-gi:armhf python3-gi-cairo:armhf ]
Remv python-gi [3.30.4-1] [python3-gi-cairo:armhf ]
Remv libgirepository-1.0-1 [1.58.3-2] [python3-gi-cairo:armhf ]
Remv python3-gi-cairo [3.30.4-1]

Dunno what alacarte is but otherwise looks okay to me to go forward without the --dry-run

I already ran it :grin:
It does seem to work better.

It fails again:

debhelper : Dépend: dh-autoreconf (>= 17~) mais ne sera pas installé

One issue is solved but not the other one.
And Yunohost depends on that package.

Installing it manually upgrade it from v19 to v20.
But it still doesn’t work.

https://paste.yunohost.org/raw/qiyasubawa (same but full log)

I tried to do apt upgrade first, it upgraded a whole bunch of packages, but then the migration fails again with that log.

Oh I spoke about this before : YunoHost 11.0 (Bullseye) release / Sortie de YunoHost 11.0 (Bullseye) - #136 by Lapineige

Running apt upgrade debhelper raises:

Les paquets suivants contiennent des dépendances non satisfaites :
libayatana-appindicator3-1 : Casse: libappindicator3-1 (< 22.04)

I removed it, it removed clipit libayatana-appindicator3-1 packages.
Doesn’t change the issue.

And then

aptitude why  debhelper
   equivs Dépend debhelper


yunohost Dépend equivs
debhelper Dépend dh-autoreconf (>= 17~)

I don’t know how to solve this… I can’t fix dh-autoreconf, nor uninstall Yunohost…

I don’t understand why that package (dh-autoreconf) is causing trouble… How can I diagnose this ? :thinking:

Trying to remove it will remove equivs and yunohost as a consequence… that’s quite bad for a migration :sweat_smile:

APT sources has been configured to point at bulleyes repositories… I don’t understand why it would not be upgraded properly.

I found a solution for another (linked ?) issue, I think.

I had this error message during apt update:

Attention : W: Skipping acquire of configured file 'ui/binary-armhf/Packages' as repository 'http://archive.raspberrypi.org/debian bullseye InRelease' doesn't have the component 'ui' (component misspelt in sources.list?)
Attention : W: Skipping acquire of configured file 'ui/i18n/Translation-en' as repository 'http://archive.raspberrypi.org/debian bullseye InRelease' doesn't have the component 'ui' (component misspelt in sources.list?)

It was from /etc/apt/sources.list.d/raspi.conf, which used the repository deb http://archive.raspberrypi.org/debian/ bullseye main ui.
ui is needed for raspberry-ui-mods, needed for X11 stuff. But I removed that package and the graphical environnement so it’s no longer needed.

The error is gone, but not my main issue.

Yeah apt is pretty fucking dumb in a lot of those situation …

I you’re familiar enough with the command line, I would give a try to (full-)upgrade using aptitude which has a much more powerful “resolver” for complex situation (and the current situation doesnt seem that complex, just that apt is kinda dumb -_-)

1 Like

I tried aptitude upgrade but that “crashed” it, I lost the SSH connection and then it was not possible to connect again.

Suppression de agnostics (0.12) ...
Suppression de bind9utils (1:9.16.33-1~deb11u1) ...
Suppression de bluealsa (0.13) ...
client_loop: send disconnect: Broken pipe

The SD card just died (mmc0 card never left busy state, flashing a new Yunohost image only succeed for the /boot partition but not the other one, …), so never mind, I will not be able to restore that backup very soon :sweat_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.