Upgrade to Bullseye not working

Hello Support team,

My YunoHost server

**Hardware: Raspberry Pi 4 at home
YunoHost version: (stable).
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | … → all
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no → bone stock
If yes, please explain:

Description of my issue

today I tried to upgrade yunohost on raspberry 4 to the current version of bullseye.
The initiall installation was done ~ 1 year ago from the official raspi immage. No tinkering - it is just working fine so far.
Using the integrated migration assistant, the process failed after: “DEBUG - Running: LC_ALL=C DEBIAN_FRONTEND=noninteractive APT_LISTCHANGES_FRONTEND=none apt install --quiet -o=Dpkg::Use-Pty=0 --fix-broken --assume-yes gcc-8- libgcc-8-dev- equivs”

Then I rebooted the raspi and tried again. The same command failed but with more broken dependencies.
Please allow me to upload the logs.

I read several posts but was not able to find a solution to my problem.
The current state is, that I reverted back to the before first attempt backup.

Please let me know what I need to change to successfuly run the update.

Thank you very much

Here are some error messages

I don’t see why you would not be able to upload the logs :neutral_face:

Thank you for picking this up.
I get the message:
“Sorry, new users can not upload attachments.”

Kind regards,

Usually you just need to press the green button “Share logs with yunopaste”, which generates a link, and you just share that link directly …

OK - since I restored the disk I don’t have links anymore. Only the downloaded files.
I’ll remember for the next try.

Thank you

I think this is the relevant portion of the log.
There was a post which might be related to this problem but for me there was no conclusive solution.
When updating the system via younohost or apt there are no errors.
Please let me know how to proceede from here.

2022-12-03 23:19:49,025: INFO - + Removing build-essential (12.6) …
2022-12-03 23:19:56,184: DEBUG - Running: LC_ALL=C DEBIAN_FRONTEND=noninteractive APT_LISTCHANGES_FRONTEND=none apt install --quiet -o=Dpkg::Use-Pty=0 --fix-broken --assume-yes gcc-8- libgcc-8-dev- equivs
2022-12-03 23:19:56,207: DEBUG -
2022-12-03 23:19:56,208: WARNING - WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
2022-12-03 23:19:56,210: DEBUG -
2022-12-03 23:19:56,278: INFO - + Reading package lists…
2022-12-03 23:19:56,830: INFO - + Building dependency tree…
2022-12-03 23:19:56,834: INFO - + Reading state information…
2022-12-03 23:19:57,681: INFO - + Some packages could not be installed. This may mean that you have
2022-12-03 23:19:57,682: INFO - + requested an impossible situation or if you are using the unstable
2022-12-03 23:19:57,684: INFO - + distribution that some required packages have not yet been created
2022-12-03 23:19:57,685: INFO - + or been moved out of Incoming.
2022-12-03 23:19:57,687: INFO - + The following information may help to resolve the situation:
2022-12-03 23:19:57,688: DEBUG -
2022-12-03 23:19:57,689: INFO - + The following packages have unmet dependencies:
2022-12-03 23:19:58,117: INFO - + equivs : Depends: debhelper but it is not going to be installed
2022-12-03 23:19:58,119: INFO - + libgirepository-1.0-1 : Breaks: python3-gi (< 3.34.0-4~) but 3.30.4-1 is to be installed
2022-12-03 23:19:58,124: INFO - + yunohost : Depends: php7.3-fpm but it is not going to be installed
2022-12-03 23:19:58,127: INFO - + Depends: php7.3-intl but it is not going to be installed
2022-12-03 23:19:58,129: INFO - + Depends: mailutils but it is not going to be installed
2022-12-03 23:19:58,189: WARNING - E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
2022-12-03 23:19:59,192: INFO - Starte Hauptupdate…
2022-12-03 23:21:52,354: INFO - Pakete werden aktualisiert…
2022-12-03 23:21:52,374: INFO - Momentan werden Upgrades für das System (YunoHost-unabhängige) Pakete durchgeführt…
2022-12-03 23:21:52,862: DEBUG - Running apt command :
DEBIAN_FRONTEND=noninteractive APT_LISTCHANGES_FRONTEND=none apt-get --fix-broken --show-upgraded --assume-yes --quiet -o=Dpkg::Use-Pty=0 -o Dpkg::Options::=“–force-confold” -o Dpkg::Options::=“–force-confmiss” -o Dpkg::Options::=“–force-confdef” dist-upgrade
2022-12-03 23:21:52,955: INFO - + Paketlisten werden gelesen…
2022-12-03 23:21:53,533: INFO - + Abhängigkeitsbaum wird aufgebaut…
2022-12-03 23:21:53,537: INFO - + Statusinformationen werden eingelesen…
2022-12-03 23:21:54,572: INFO - + Paketaktualisierung (Upgrade) wird berechnet…
2022-12-03 23:21:54,574: INFO - + Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
2022-12-03 23:21:54,575: INFO - + Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
2022-12-03 23:21:54,576: INFO - + Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
2022-12-03 23:21:54,578: INFO - + nicht erstellt wurden oder Incoming noch nicht verlassen haben.
2022-12-03 23:21:54,579: INFO - + Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
2022-12-03 23:21:54,580: DEBUG -
2022-12-03 23:21:54,581: INFO - + Die folgenden Pakete haben unerfüllte Abhängigkeiten:
2022-12-03 23:21:55,021: INFO - + libc6-dev : Beschädigt: libgcc-8-dev (< 8.4.0-2~) aber 8.3.0-6+rpi1 soll installiert werden
2022-12-03 23:21:55,079: WARNING - E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.

Let’s try to apt remove python3-gi --dry-run, and then without the --dry-run if the simulation isnt too spooky


thank you - the upgrade went further. But I got stuck again.
The Log is found here:
Do you have an Idea what to change in this case?

Thank you

I think I would try to apt remove libgirepository-1.0-1 --dry-run, and then without the --dry-run if the simulation isnt too spooky

by the looks the server might fall apart.
It seems that java will not work. About X11 I’m not worried.
In essence what will not work / has to be checked after removing libgirepository-1.0-1?

thank you

sudo apt remove libgirepository-1.0-1 --dry-run

Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
ca-certificates-java default-jre-headless freerdp2-dev
gstreamer1.0-plugins-base icu-devtools java-common libapr1 libavcodec-dev
libavformat-dev libavutil-dev libblkid-dev libcairo-gobject2
libcairo-script-interpreter2 libcairo2-dev libcdparanoia0
libeclipse-jdt-core-java libev-dev libev4 libffi-dev libfontconfig1-dev
libfreerdp-client2-2 libfreerdp-server2-2 libfreerdp-shadow-subsystem2-2
libfreerdp-shadow2-2 libfreerdp2-2 libfribidi-dev libgcrypt20-dev
libglib2.0-bin libglib2.0-dev libglib2.0-dev-bin libgmp-dev libgmpxx4ldbl
libgnutls-dane0 libgnutls-openssl27 libgnutls28-dev libgnutlsxx28
libgpg-error-dev libgraphite2-dev libgstreamer-plugins-base1.0-0
libgstreamer1.0-0 libharfbuzz-gobject0 libharfbuzz-icu0 libice-dev
libicu-dev libidn2-dev libjpeg62-turbo-dev libmount-dev libnspr4 libnss3
libogg-dev liborc-0.4-0 libossp-uuid-dev libossp-uuid16 libp11-kit-dev
libpangoxft-1.0-0 libpcre16-3 libpcre3-dev libpcre32-3 libpcrecpp0v5
libpixman-1-dev libpthread-stubs0-dev libpulse-dev libpulse-mainloop-glib0
libselinux1-dev libsepol1-dev libsm-dev libssh2-1-dev libswresample-dev
libswscale-dev libtasn1-6-dev libtasn1-doc libtcnative-1 libtelnet-dev
libtelnet2 libtomcat9-java libtool-bin libvisual-0.4-0 libvncclient1
libvncserver-config libvncserver-dev libvncserver1 libvorbis-dev libwebp-dev
libwebsockets-dev libwebsockets8 libwinpr-tools2-2 libwinpr2-2 libwinpr2-dev
libx11-dev libxau-dev libxcb-render0-dev libxcb-shm0-dev libxcb1-dev
libxdmcp-dev libxext-dev libxft-dev libxkbfile1 libxrender-dev nettle-dev
openjdk-11-jre-headless pango1.0-tools tomcat9 tomcat9-common winpr-utils
x11proto-core-dev x11proto-dev x11proto-xext-dev xorg-sgml-doctools
Use ‘sudo apt autoremove’ to remove them.
The following packages will be REMOVED:
gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-glib-2.0 gir1.2-harfbuzz-0.0
gir1.2-pango-1.0 guacamole-ynh-deps libgdk-pixbuf2.0-dev
libgirepository-1.0-1 libharfbuzz-dev libpango1.0-dev
0 upgraded, 0 newly installed, 10 to remove and 0 not upgraded.
Remv guacamole-ynh-deps [1.4.0~ynh1]
Remv libpango1.0-dev [1.42.4-8~deb10u1]
Remv gir1.2-pango-1.0 [1.42.4-8~deb10u1]
Remv gir1.2-freedesktop [1.58.3-2]
Remv libgdk-pixbuf2.0-dev [2.38.1+dfsg-1]
Remv gir1.2-gdkpixbuf-2.0 [2.38.1+dfsg-1]
Remv libharfbuzz-dev [2.3.1-1]
Remv gir1.2-harfbuzz-0.0 [2.3.1-1]
Remv gir1.2-glib-2.0 [1.58.3-2]
Remv libgirepository-1.0-1 [1.58.3-2]

From the look of it, it’s not that “java will not work anymore”, it’s more that some java-related dependencies are not needed anymore, because removing libgirepository implies the removal of guacamole which depends on other dependencies, thus those dependencies are flagged as “not needed anymore”

I guess a cleaner way to address the situation would be to uninstall the guacamole app from yunohost webadmin (or cli), though you can probably reinstall it after the bullseye migration is over

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.