Upgrade Redmine fails from version 4.2.7~ynh1 to 5.0.4~ynh1

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.0.11 (stable)
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:
If your request is related to an app, specify its name and version: Redmine 4.2.7~ynh1

Description of my issue

I used webadmin to upgrade Redmine from 4.2.7~ynh1 to 5.0.4~ynh1. Upgrade process fails but can restore backup.
Here is the link to the paste https://paste.yunohost.org/raw/emeyefadir
Maybe the error is in this lines:

2023-01-21 18:33:28,868: DEBUG - + ynh_exec_warn_less bundle exec rake db:migrate RAILS_ENV=production
2023-01-21 18:33:28,868: DEBUG - + [[ 5 -eq 1 ]]
2023-01-21 18:33:28,869: DEBUG - + bundle exec rake db:migrate RAILS_ENV=production
2023-01-21 18:33:33,233: DEBUG - rake aborted!
2023-01-21 18:33:33,238: DEBUG - LoadError: cannot load such file -- open_id_authentication

Does anybody have the same issue?

Thank you.

Davide