Update Searx to 0.12.0?

Is there any work being done on bringing the latest update of Searx to yunohost?

The work is ongoing (see this PR) and that’ll get published as soon as the validation process is achieved :wink:

Ok sweet I hope this is done sooner rather than later. Do you by any chance know where Yunohost puts the files so I could edit the html\css?

Searx files are located in /opt/yunohost/searx.

Thanks. After updating the html what do I do so the app refreshes and uses my updated code? For example I want to change the name of the instance from YunoSearx to MetaSearx. It’s normally in in searx/searx/settings.yml but in the yunohost app that file doesn’t have YunoSearx in it’s instance name even though it displays YunoSearx on the website.

any idea about ^

Changing the name in the file will change the searx name.

after changing it what should be done so the changes are loaded?

nginx and ssowat reload

are the commands

sudo nginx service restart


sudo ssowat service restart


service nginx restart
yunohost app ssowatconf

when doing

service nginx restart

I get

-bash: service: command not found

and when doing

sudo service nginx restart

I get

Job for nginx.service failed. See ‘systemctl status nginx.service’ and ‘journalctl -xn’ for details.

Can you show journalctl -xn ?

nvm I was actually doing this on the wrong server.

when doing

service nginx restart

I get

-bash: service: command not found

and when doing

sudo service nginx restart

I get no error or confirmation and the instance doesn’t update. So far the only way I can get it to update is by doing

sudo reboot

service uwsgi restart

That worked! Thanks!

sudo uwsgi restart
sudo yunohost app ssowatconf

are the commands needed for anyone else who might wonder

1 Like

still no update to the PR :’( has it been forgotten about?


Maybe some people in the Apps Group are taking some well-deserved vacations…? :wink:

But you may be the man of the situation!
Now people from the community can validate the test part of the Apps PR. So, you may help us check the two remaining checkboxes : Complete test, Upgrade previous version!

If you feel brave enough, you can test the release on a server/VM of your own by using this URL for installation or upgrade: https://github.com/YunoHost-Apps/searx_ynh/tree/enh_searx_0.12.0

So, updating would be done on the CLI like that:

yunohost app upgrade -u https://github.com/YunoHost-Apps/searx_ynh/tree/enh_searx_0.12.0 searx --verbose

Good luck! :wink:

everything thing seems to be working except when I do sudo uswgi restart i get

unable to load configuration from restart

EDIT: The Google engine doesn’t seem to be working. Not sure if google has cut off support for their api which iirc they were going to do. EDIT 2: Google engine is working again not sure what changed.

A new version of Searx (0.13.1) has been out for a couple of days now. It would be nice if the app list displayed the current version of the app Yunohost has