Update error Piwigo

I have a error by updating piwigo,
Here the LOG File
Maybe someone knows the problem

There was a similar issue in [Résolu] Pb installation Piwigo - #13 by fibule

The fix/workaround was to edit the settings file for piwigo:

nano /etc/yunohost/apps/piwigo/settings.yml

and replace the value for admin_pwd with the actual admin password

Hey Aleks,
I also found a password in the file that I did not assign.
I changed it to my password, but I have a ‘+’ in my password.
So Yunohost no longer ran and I got an error message.
Veined again, meanwhile changed to Piwigo.
Now I’ve screwed it up somehow, I can no longer log in to piwigo as admin.
I think the best thing would be to restore the piwigo data backup.
do I have to delete piwigo first?

I managed to bring everything back to its old state.
However, the update does not work. The same error message.
The update is also offered to me in Piwigo. Can I start it there?
or do I have to change my PW completely without ‘+’ as a special character

If adding the + in the file was causing an issue, you probably need to wrap the password in quotes. Something like :

admin_pwd: "your+actual+password"

(note that the quotes won’t count as being part of the password, that’s just for the yaml syntax)

I changed it like you wrote but no difference

so updat is done. I changed the PW in Piwigo without + and adjusted the /etc/yunohost/apps/piwigo/settings.yml file. That’s how it worked

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.