Update DNS settings to point to new IP

,

My YunoHost server

Hardware: Internet Cube with VPN
YunoHost version: 3.5.2
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

I’ve successfully set up a VPN in a clean Yunohost install. VPN status is running (ynh-vpnclient-checker status is inactive, I’m not sure why) and I can access my server outside my home network through SSH and webadmin using the IP provided by FAImaison.

But I didn’t figure out how I can update DNS settings to point to my new unique IP. I’m using a nohost.me domain (solnik.nohost.me). Is that possible or do I have to own a domain to do it?

If you have created your nohost.me domain from the webadmin, your domain should update the IP automatically.

If you have use the command line, it could be possible you miss the --dyndns option to indicate to setup the cron task to regularly update the IP when you added the domain:

yunohost domain add DOMAIN.nohost.me --dyndns

The command

yunohost dyndns --help

and its subcommand

yunohost dyndns subscribe --help
yunohost dyndns installcron --help
yunohost dyndns update --help

could help you.

Thanks for your answer. I forgot to say that I’ve tried those commands before.

When I type yunohost dyndns subscribe -d solnik.nohost.me I get: Error: You've already subscribed to a DynDNS domain

yunohost dyndns installcron gives me Success! The DynDNS cron job has been installed

When I try to update, I get the following error:

root@solnik:/home/admin# yunohost dyndns update -d solnik.nohost.me -i MY_IP
Traceback (most recent call last):
  File "/usr/bin/yunohost", line 213, in <module>
    timeout=opts.timeout,
  File "/usr/lib/python2.7/dist-packages/moulinette/__init__.py", line 136, in cli
    moulinette.run(args, output_as=output_as, password=password, timeout=timeout)
  File "/usr/lib/python2.7/dist-packages/moulinette/interfaces/cli.py", line 425, in run
    ret = self.actionsmap.process(args, timeout=timeout)
  File "/usr/lib/python2.7/dist-packages/moulinette/actionsmap.py", line 523, in process
    return func(**arguments)
  File "/usr/lib/moulinette/yunohost/log.py", line 273, in func_wrapper
    result = func(*args, **kwargs)
  File "/usr/lib/moulinette/yunohost/dyndns.py", line 235, in dyndns_update
    old_ipv4 = check_output("dig @%s +short %s" % (dyn_host, domain)).strip() or None
  File "/usr/lib/python2.7/dist-packages/moulinette/utils/process.py", line 29, in check_output
    return subprocess.check_output(args, stderr=stderr, shell=shell, **kwargs)
  File "/usr/lib/python2.7/subprocess.py", line 219, in check_output
    raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command 'dig @dyndns.yunohost.org +short solnik.nohost.me' returned non-zero exit status 10

What happens if you run manually this command ?

dig @dyndns.yunohost.org +short solnik.nohost.me

If VPN is enabled, I get the following error: dig: couldn't get address for 'dyndns.yunohost.org': failure

If VPN is disabled, I get my modem’s IP as a result.

I’ve tried changing my DNS settings with VPN turned off, but it didn’t work:

root@solnik:/home/admin# yunohost dyndns update -d solnik.nohost.me -i 89.234.177.82
Info: Updated needed, going on...
Outgoing update query:
;; ->>HEADER<<- opcode: UPDATE, status: NOERROR, id:      0
;; flags:; ZONE: 0, PREREQ: 0, UPDATE: 0, ADDITIONAL: 0
;; ZONE SECTION:
;nohost.me.			IN	SOA

;; UPDATE SECTION:
_xmpp-client._tcp.solnik.nohost.me. 0 ANY ANY	
_xmpp-server._tcp.solnik.nohost.me. 0 ANY ANY	
muc.solnik.nohost.me.	0	ANY	ANY	
pubsub.solnik.nohost.me. 0	ANY	ANY	
vjud.solnik.nohost.me.	0	ANY	ANY	
solnik.nohost.me.	0	ANY	ANY	
solnik.nohost.me.	0	ANY	ANY	
mail._domainkey.solnik.nohost.me. 0 ANY	ANY	
_dmarc.solnik.nohost.me. 0	ANY	ANY	
solnik.nohost.me.	0	ANY	ANY	
*.solnik.nohost.me.	0	ANY	ANY	
solnik.nohost.me.	0	ANY	ANY	
*.solnik.nohost.me.	0	ANY	ANY	
_xmpp-client._tcp.solnik.nohost.me. 3600 IN SRV	0 5 5222 solnik.nohost.me.
_xmpp-server._tcp.solnik.nohost.me. 3600 IN SRV	0 5 5269 solnik.nohost.me.
muc.solnik.nohost.me.	3600	IN	CNAME	solnik.nohost.me.
pubsub.solnik.nohost.me. 3600	IN	CNAME	solnik.nohost.me.
vjud.solnik.nohost.me.	3600	IN	CNAME	solnik.nohost.me.
solnik.nohost.me.	3600	IN	MX	10 solnik.nohost.me.
solnik.nohost.me.	3600	IN	TXT	"v=spf1 a mx ip4:189.100.14.167 ip6:2804:14c:46:8649:48:8ff:fec2:b5e1 -all"
mail._domainkey.solnik.nohost.me. 3600 IN TXT	"v=DKIM1; h=sha256; k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDshZ7mC4Tk1mhqLzk0L6G/qryuFV+VrIsVSJ8prnIPEIwCoCtcopno8tcI9H2LUIcR0e4u7mfXbsi4zTpAL0pTVQBEhRsW/2q2a9EKwvrNvBMDDFKxeOT8X3xNhvniWPcRk/cAIY3ksDS4jRdl5dGfcDokbigD2RpBzcjjbUAP5wIDAQAB"
_dmarc.solnik.nohost.me. 3600	IN	TXT	"v=DMARC1; p=none"
solnik.nohost.me.	3600	IN	A	189.100.14.167
*.solnik.nohost.me.	3600	IN	A	189.100.14.167
solnik.nohost.me.	3600	IN	AAAA	2804:14c:46:8649:48:8ff:fec2:b5e1
*.solnik.nohost.me.	3600	IN	AAAA	2804:14c:46:8649:48:8ff:fec2:b5e1

Success! Your IP address has been updated on DynDNS

Could you try to ping from your internet cubre an other website and an other ip when your VPN is up:

ping 9.9.9.9
ping wikipedia.org

When the VPN is up, could you display your /etc/resolv.conf file:

cat /etc/resolv.conf

ping is working fine:

root@solnik:/home/admin# ping -c 10 9.9.9.9
PING 9.9.9.9 (9.9.9.9) 56(84) bytes of data.
64 bytes from 9.9.9.9: icmp_seq=1 ttl=244 time=63.2 ms
64 bytes from 9.9.9.9: icmp_seq=2 ttl=244 time=63.5 ms
64 bytes from 9.9.9.9: icmp_seq=3 ttl=244 time=64.1 ms
64 bytes from 9.9.9.9: icmp_seq=4 ttl=244 time=63.4 ms
64 bytes from 9.9.9.9: icmp_seq=5 ttl=244 time=63.4 ms
64 bytes from 9.9.9.9: icmp_seq=6 ttl=244 time=63.7 ms
64 bytes from 9.9.9.9: icmp_seq=7 ttl=244 time=64.8 ms
64 bytes from 9.9.9.9: icmp_seq=8 ttl=244 time=63.6 ms
64 bytes from 9.9.9.9: icmp_seq=9 ttl=244 time=64.0 ms
64 bytes from 9.9.9.9: icmp_seq=10 ttl=244 time=62.2 ms

--- 9.9.9.9 ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 9013ms
rtt min/avg/max/mdev = 62.259/63.637/64.837/0.662 ms

ping wikipedia.org works as well.

/etc/resolv.conf file:

root@solnik:/home/admin# cat /etc/resolv.conf 
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.0.1
cat /etc/resolv.dnsmasq.conf
service dnsmasq status
root@solnik:/etc/resolvconf# cat /etc/resolv.dnsmasq.conf 
nameserver 2001:4ce8::53
nameserver 194.150.168.168
nameserver 91.239.100.100
nameserver 2a00:5884:8218::1
nameserver 89.233.43.71
nameserver 84.200.70.40
nameserver 80.67.188.188
nameserver 185.233.100.101
nameserver 195.160.173.53
nameserver 2a00:5881:8100:1000::3
nameserver 80.67.169.40
nameserver 84.200.69.80
nameserver 2001:67c:28a4::
nameserver 2a0c:e300::100
nameserver 89.234.141.66
nameserver 2001:1608:10:25::9249:d69b
nameserver 2001:910:800::12
nameserver 85.214.20.141
nameserver 2001:913::8
nameserver 80.67.169.12
nameserver 185.233.100.100
nameserver 2001:1608:10:25::1c04:b12f
nameserver 2a0c:e300::101
nameserver 2002:d596:2a92:1:71:53::
nameserver 2001:910:800::40
nameserver 80.67.190.200
root@solnik:/etc/resolvconf# service dnsmasq status
● dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server
   Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled; vendor preset: 
   Active: active (running) since Thu 2019-05-23 02:13:15 UTC; 10h ago
 Main PID: 5459 (dnsmasq)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/dnsmasq.service
           └─5459 /usr/sbin/dnsmasq -x /run/dnsmasq/dnsmasq.pid -u dnsmasq -7 /e

May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2001:910:800::1
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 85.214.20.141#5
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2001:913::8#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 80.67.169.12#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 185.233.100.100
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2001:1608:10:25
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2a0c:e300::101#
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2002:d596:2a92:
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2001:910:800::4
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 80.67.190.200#5
lines 1-18/18 (END)...skipping...
● dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server
   Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2019-05-23 02:13:15 UTC; 10h ago
 Main PID: 5459 (dnsmasq)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/dnsmasq.service
           └─5459 /usr/sbin/dnsmasq -x /run/dnsmasq/dnsmasq.pid -u dnsmasq -7 /etc/dnsmasq.d,.dpkg-dist,.dpkg-old,.dpkg-new --local-service

May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2001:910:800::12#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 85.214.20.141#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2001:913::8#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 80.67.169.12#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 185.233.100.100#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2001:1608:10:25::1c04:b12f#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2a0c:e300::101#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2002:d596:2a92:1:71:53::#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2001:910:800::40#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 80.67.190.200#53

Your VPN is running when you tried this commands ? Especially ping wikipedia.org ?

sorry, my bad! now with VPN running:

ping 9.9.9.9 works

root@solnik:/home/admin# ping -c 10 wikipedia.org
ping: wikipedia.org: Temporary failure in name resolution
root@solnik:/home/admin# cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.0.1
root@solnik:/home/admin# cat /etc/resolv.dnsmasq.conf
nameserver 89.234.176.137
nameserver 91.224.149.120
root@solnik:/home/admin# service dnsmasq status
● dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server
   Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2019-05-23 02:13:15 UTC; 10h ago
 Main PID: 5459 (dnsmasq)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/dnsmasq.service
           └─5459 /usr/sbin/dnsmasq -x /run/dnsmasq/dnsmasq.pid -u dnsmasq -7 /etc/dnsmasq.d,.dpkg-dist,.dpkg-old,.dpkg-new --local-service

May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2001:1608:10:25::1c04:b12f#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2a0c:e300::101#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2002:d596:2a92:1:71:53::#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 2001:910:800::40#53
May 23 02:50:15 solnik.nohost.me dnsmasq[5459]: using nameserver 80.67.190.200#53
May 23 13:01:57 solnik.nohost.me dnsmasq[5459]: reading /etc/resolv.dnsmasq.conf
May 23 13:01:57 solnik.nohost.me dnsmasq[5459]: using nameserver 89.234.176.137#53
May 23 13:01:57 solnik.nohost.me dnsmasq[5459]: reading /etc/resolv.dnsmasq.conf
May 23 13:01:57 solnik.nohost.me dnsmasq[5459]: using nameserver 89.234.176.137#53
May 23 13:01:57 solnik.nohost.me dnsmasq[5459]: using nameserver 91.224.149.120#53

Si tu as utilisé un .cube pour configurer ton VPN via VPN client, les serveurs DNS du .cube ne semblent pas fonctionner (il ne fonctionne pas chez moi):

89.234.176.137
91.224.149.120

dig +short A wikipedia.org @89.234.176.137

et

dig +short A wikipedia.org @91.224.149.120

ne donner rien

Peut être une panne des DNS de ton fournisseur de VPN ?

Tu peux modifier ces DNS en utilisant d’autres DNS ouvert, voir ici par exemple:
https://arn-fai.net/recursif

Ok, I’ve updated my DNS servers:

"dns0": "89.234.141.66",
"dns1": "80.67.188.188",

But, still, my IP didn’t automatically change, so I tried to update it manually:

root@solnik:/home/admin# yunohost dyndns update
Info: Updated needed, going on...
Outgoing update query:
;; ->>HEADER<<- opcode: UPDATE, status: NOERROR, id:      0
;; flags:; ZONE: 0, PREREQ: 0, UPDATE: 0, ADDITIONAL: 0
;; ZONE SECTION:
;nohost.me.			IN	SOA

;; UPDATE SECTION:
_xmpp-client._tcp.solnik.nohost.me. 0 ANY ANY	
_xmpp-server._tcp.solnik.nohost.me. 0 ANY ANY	
muc.solnik.nohost.me.	0	ANY	ANY	
pubsub.solnik.nohost.me. 0	ANY	ANY	
vjud.solnik.nohost.me.	0	ANY	ANY	
solnik.nohost.me.	0	ANY	ANY	
solnik.nohost.me.	0	ANY	ANY	
mail._domainkey.solnik.nohost.me. 0 ANY	ANY	
_dmarc.solnik.nohost.me. 0	ANY	ANY	
solnik.nohost.me.	0	ANY	ANY	
*.solnik.nohost.me.	0	ANY	ANY	
_xmpp-client._tcp.solnik.nohost.me. 3600 IN SRV	0 5 5222 solnik.nohost.me.
_xmpp-server._tcp.solnik.nohost.me. 3600 IN SRV	0 5 5269 solnik.nohost.me.
muc.solnik.nohost.me.	3600	IN	CNAME	solnik.nohost.me.
pubsub.solnik.nohost.me. 3600	IN	CNAME	solnik.nohost.me.
vjud.solnik.nohost.me.	3600	IN	CNAME	solnik.nohost.me.
solnik.nohost.me.	3600	IN	MX	10 solnik.nohost.me.
solnik.nohost.me.	3600	IN	TXT	"v=spf1 a mx ip4:89.234.177.82 -all"
mail._domainkey.solnik.nohost.me. 3600 IN TXT	"v=DKIM1; h=sha256; k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDshZ7mC4Tk1mhqLzk0L6G/qryuFV+VrIsVSJ8prnIPEIwCoCtcopno8tcI9H2LUIcR0e4u7mfXbsi4zTpAL0pTVQBEhRsW/2q2a9EKwvrNvBMDDFKxeOT8X3xNhvniWPcRk/cAIY3ksDS4jRdl5dGfcDokbigD2RpBzcjjbUAP5wIDAQAB"
_dmarc.solnik.nohost.me. 3600	IN	TXT	"v=DMARC1; p=none"
solnik.nohost.me.	3600	IN	A	89.234.177.82
*.solnik.nohost.me.	3600	IN	A	89.234.177.82

; Communication with 2a03:7220:8080:5c00::1#53 failed: operation canceled
update failed: FORMERR
Info: The operation 'Update the ip associated with your YunoHost subdomain 'solnik.nohost.me'' has failed! To get help, please share the full log of this operation using the command 'yunohost log display 20190523-135823-dyndns_update-solnik.nohost.me --share'
Error: Unable to update IP address on DynDNS

full log:

args:
  domain: null
  dyn_host: dyndns.yunohost.org
  ipv4: null
  ipv6: null
  key: null
ended_at: 2019-05-23 14:01:04.692635
error: Unable to update IP address on DynDNS
operation: dyndns_update
related_to:
- - domain
  - solnik.nohost.me
started_at: 2019-05-23 13:58:23.198849
success: false

============

2019-05-23 13:58:23,213: INFO - Updated needed, going on...
2019-05-23 13:58:54,362: DEBUG - Could not get public IPv6 : Invalid url https://ip6.yunohost.org (does this site exists?)
2019-05-23 13:58:54,375: DEBUG - system hook folder not found for action 'custom_dns_rules' in /usr/share/yunohost/hooks/
2019-05-23 13:58:54,377: DEBUG - custom hook folder not found for action 'custom_dns_rules' in /etc/yunohost/hooks.d/
2019-05-23 13:58:54,380: DEBUG - Now pushing new conf to DynDNS host...

Your ipv6 seems broken.

To check that try to ping with v6 protocol:

ping6 wikipedia.org

Check you have an ipv6 with ifconfig

It might be because of missing ipv6 dns resolver ?

If I try to ping or ping6 wikipedia.org I get:

root@solnik:/home/admin# ping -c 5 wikipedia.org
PING wikipedia.org(text-lb.esams.wikimedia.org (2620:0:862:ed1a::1)) 56 data bytes
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted

--- wikipedia.org ping statistics ---
5 packets transmitted, 0 received, 100% packet loss, time 4096ms

root@solnik:/home/admin# ping6 -c 5 wikipedia.org
PING wikipedia.org(text-lb.esams.wikimedia.org (2620:0:862:ed1a::1)) 56 data bytes
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
root@solnik:/home/admin# ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.14  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 2804:14c:46:8649:48:8ff:fec2:b5e1  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::48:8ff:fec2:b5e1  prefixlen 64  scopeid 0x20<link>
        inet6 fe80::42:acab  prefixlen 128  scopeid 0x20<link>
        ether 02:48:08:c2:b5:e1  txqueuelen 1000  (Ethernet)
        RX packets 4264  bytes 1158004 (1.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 7374  bytes 6766564 (6.4 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 56  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 3615  bytes 1372959 (1.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3615  bytes 1372959 (1.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

tun0: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>  mtu 1500
        inet 89.234.177.82  netmask 255.255.255.192  destination 89.234.177.82
        inet6 fe80::f589:23a2:de43:bbd2  prefixlen 64  scopeid 0x20<link>
        unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  txqueuelen 100  (UNSPEC)
        RX packets 822  bytes 84944 (82.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1228  bytes 1264317 (1.2 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

It might be because of missing ipv6 dns resolver ?

How can I solve that?

It seems your vpn doesn’t configure ipv6, but your isp yes…
I think it’s a bug with your vpn or your .cube.

Disable ipv6 in your system could fix it temporarily:
sysctl -w net.ipv6.conf.all.disable_ipv6=1*

Could you check your .cube includes ipv6 parameters ?

This is my .cube:

{
“server_name”: “vpn.faimaison.net”,
“server_port”: “443”,
“server_proto”: “udp”,
“ip6_net”: “”,
“ip4_addr”: “89.234.177.82”,
“crt_server_ca”: “XXX”,
“crt_client”: “”,
“crt_client_key”: “”,
“crt_client_ta”: “”,
“login_user”: “XXX”,
“login_passphrase”: “XXX”,
“dns0”: “89.234.141.66”,
“dns1”: “80.67.188.188”,
“openvpn_rm”: [
“comp-lzo adaptive”,
“route-ipv6”
],
“openvpn_add”: [
“redirect-gateway def1”,
“route-method exe”,
“route-delay 2”,
“ns-cert-type server”,
“verify-x509-name vpn.faimaison.net name”
]
}

That’s it: no ipv6. Ask for ipv6 to your vpn provider or if they can’t you can disable definetly ipv6 on your server.

sysctl -w net.ipv6.conf.all.disable_ipv6=1
echo 'net.ipv6.conf.all.disable_ipv6 = 1 ' >> /etc/sysctl.conf
1 Like