Unknown Pasword inside shell

My YunoHost server

Hardware: Raspberry Pi 4) at home
YunoHost version:
I have access to my server : Through SSH & through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi! Sorry for the trouble… I’m trying to alter the .env file inside of the funkwhale shell, and running into a problem where I need a password, and my admin password apparently doesn’t work.

Entering sudo nano /srv/funkwhale/config/.env should open the file, but it gives me the spiel about talking to the local system admin and asks for [sudo] password for funkwhale: and then doesn’t accept either the admin password for YunoHost or the password for the funkwhale admin (which should be the same anyways).

I’d like to change the funkwhale account registration requirements, as well as a few other internal settings, but have not been able to do so because the sudo password for outside the shell apparently doesn’t work inside the shell.

Is there a way to find/reset the password so I can access these things? Or a workaround? Thanks in advance!

Please explicitly state all the commands you are running. :slight_smile:


The easiest way to reproduce it is:


sudo su
yunohost app shell funkwhale
sudo su

which will then ask you for the password for funkwhale which, for me, nothing worked. Thus, inside the shell, which I can’t access without sudo access, I can’t do anything because it requires sudo access?

Thanks again for your assistance!

Congrats, you are the first to publicly try this new feature. :heart:

You should normally not need to do sudo su once more when the shell is opened for Funkwhale. :wink: Can you check how the files look like in there with a ls -la?

Especially this /srv/funkwhale/config/.env does not look right. How did you get that path? My guess would be a simple config/.env.

funkwhale@<hidmydomain>:~$ ls -la
total 32
drwxr-x---  7 funkwhale www-data  4096 Jun 26 23:04 .
drwxr-xr-x+ 5 root      root      4096 Jun 26 05:50 ..
drwxr-x---  5 funkwhale www-data  4096 Jun 26 05:59 api
-rw-------  1 funkwhale funkwhale  291 Jun 27 10:59 .bash_history
drwxr-x---  2 funkwhale www-data  4096 Jun 26 23:59 config
drwxr-x---  3 funkwhale www-data  4096 Jun 26 05:53 front
drwxr-xr-x  3 funkwhale funkwhale 4096 Jun 26 19:41 .local
drwxr-x---  6 funkwhale www-data  4096 Jun 26 05:54 venv

I was following the official app documentation from Funkwhale regarding where the .env would be

I suppose we can mark this as solved, I spent some time puttering around not in the app shell, and found the .env file at /var/www/funkwhale/config/.env and was able to open it there. I guess if opening the shell is supposed to have allowed me to access things easier/faster/without hunting for a half hour, then it’s still a bug… but at least my problem is solved!

The official documentation assumes Funkwhale has been installed with Docker, I guess. The right way is as I suggested:

sudo yunohost app shell funkwhale
# here you are in /var/www/funkwhale
nano config/.env


The documentation I was looking at was for the Debian installation, and I was able to get into the .env file through your route when trying it just now, but it also is not writable in that state, which would not work for me.

Ah, good catch. We’ll see if we need to alter the configuration file permissions.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.