Universal Raspberry Pi image

,

Bonjour @petrus,

Tu peux essayer de regarder ici : http://avignu.wiki.tuxfamily.org/doku.php?id=documentation:yunohost-jessie
Ça fait repartir de zéro mais bon.

Sinon, pour le update-rc.d: error: no runlevel symlinks to modify, aborting! ça le fait a priori systématiquement, mais ça n’est pas bloquant car la procédure se poursuit.

ppr

Bonjour,

Maintenant tout est là https://yunohost.org/#/install_on_raspberry_fr et l’image ici https://build.yunohost.org/ :slight_smile:
Y’a plus qu’à !

Merci à toute l’équipe du projet ainsi qu’à tous les contributeurs ! <3

ppr

1 Like

Merci pour cette image 2.5 !

Premier test sur le RPi 1B, avec cette nouvelle image :

  1. post-installation directement sur la console du pi est cafouilleuse… (comme sur la précédente image)
  2. passage en ssh > root:yunohost (penser à mettre à jour la doc officielle qui indique le mdp “raspberry” pour root par défaut!!! ca évitera quelques dépressions aiguës)
  3. yunohost tools postinstall
  4. apt-get update && apt-get upgrade && apt-get dist-upgrade && apt-get autoclean && apt-get autoremove
  5. reboot

A voir la suite :wink:

Coucou,

merci pour le retour, j’ai fixé le password dans la doc, merci !

Tu peux préciser ce qui est cafouilleur pour la postinstall “comme sur la précédente image” ?

Parfait ! Merci :slight_smile:

Sinon à propos de la post-install directement sur le RPi : à la 2eme question où on te demande ton nom de domaine, des caractères étonnants s’inscrivent à chaque touche pressée, idem lorsque tu veux effacer les âneries avec la touche retour… ca n’efface pas, ca inscrit encore d’autres trucs zarbis… bref le clavier est inutilisable pour taper un mot :s

Tu es en ssh ou sur le raspi direct ? Car ça fait ça quand il y a une mauvaise configuration du clavier. Un raspi-config sur le raspi puis localisation keyboard et tu réglé ton clavier en vf

Oui branché en direct.
Sinon je ne me suis pas pris la tête pour le raspi-config et la config clavier dans un premier temps. Mais ce sera à faire via ssh, vu que le clavier tape n’importe quoi quand il est branché dessus…!

Quelques trucs qui me titillent :

  • une fois Roundcude installé, il manque apparemment des dépendances, et du coup ca bloque toute installation future… le message console me dit : apt-get install -f. Avec 1 paquet non vérifié, ca ne donne pas envie…
  • rspamd, ne se lance pas. Aucune info trouvée dans /var/log/syslog
  • serveur cardav/caldav ? J’apercois Baikal à installer (comment paramétrer ce bidule?), mais la doc parle de Radicale (qui n’apparait pas dans la liste des apps installables)
  • Firefoxsync dans la doc, mais non disponible ?

En ssh pour moi en tout cas je n’ai jamais réussi à paramétrer le clavier toujours un message d’erreur :s il faut savoir que le raspi par défaut est en qwerty ci jamais. Baikal est simpa et radical aussi c’est une question de choix je pense.
Lien de radical : https://github.com/YunoHost-Apps/radicale_ynh

Pour roundcube je te le déconseille le temps qu’il y est une maj car il ne permet pas d’envoyer de mail un problème de déclaration de host je pense, je te conseil rainloop beaucoup plus convivial.
https://github.com/scith/rainloop_ynh

Pour firefox sync c’est ici https://github.com/abeudin/ffsync_ynh mais il n’a pas été mis a jour depuis janvier 2016 et est expérimental

Voila voila :wink:

bonjour
chez moi l’installation s’est faite sans problème
par contre impossible d’installer nextcloud il me dit que la version est incompatible avec le système. Une idée de comment je pourrai y remédier ?

Bonsoir @tuxrouge,

As-tu bien la dernière version de YunoHost ainsi que tous les paquets à jour ?
Tu peux envoyer ces quelques commandes pour faire la mise à jour avant d’essayer de réinstaller NextCloud :

sudo apt update && sudo apt dist-upgrade && sudo apt-get autoremove && sudo apt-get autoclean

ppr

apt update && sudo apt dist-upgrade && sudo apt-get autoremove && sudo apt-get autoclean
Hit http://repo.yunohost.org jessie InRelease
Hit http://repo.yunohost.org jessie/stable armhf Packages
Ign http://repo.yunohost.org jessie/stable Translation-en_GB
Ign http://repo.yunohost.org jessie/stable Translation-en
Hit http://mirrordirector.raspbian.org jessie InRelease
Hit http://mirrordirector.raspbian.org jessie/main armhf Packages
Hit http://mirrordirector.raspbian.org jessie/contrib armhf Packages
Hit http://mirrordirector.raspbian.org jessie/non-free armhf Packages
Hit http://mirrordirector.raspbian.org jessie/rpi armhf Packages
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Hit http://archive.raspberrypi.org jessie InRelease
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Hit http://archive.raspberrypi.org jessie/ui armhf Packages
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Reading package lists… Done
Building dependency tree
Reading state information… Done
1 package can be upgraded. Run ‘apt list --upgradable’ to see it.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages have been kept back:
metronome
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists… Done
Building dependency tree
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Del raspberrypi-kernel 1.20161215-1 [30.1 MB]
Del raspberrypi-sys-mods 20161220 [8,472 B]
Del php5-gd 5.6.29+dfsg-0+deb8u1 [23.2 kB]
Del dovecot-imapd 1:2.2.13-12~deb8u1 [628 kB]
Del yunohost 2.5.3.1 [150 kB]
Del bind9utils 1:9.9.5.dfsg-9+deb8u9 [158 kB]
Del libgtk2.0-common 2.24.25-3+deb8u1 [3,185 kB]
Del libasound2 1.0.28-1+rpi2 [322 kB]
Del libjasper1 1.900.1-debian1-2.4+deb8u1 [110 kB]
Del git-man 1:2.1.4-2.1+deb8u2 [1,267 kB]
Del mariadb-client-10.0 10.0.29-0+deb8u1 [1,020 kB]
Del php5-common 5.6.29+dfsg-0+deb8u1 [720 kB]
Del libirs-export91 1:9.9.5.dfsg-9+deb8u9 [36.5 kB]
Del mysql-common 5.5.54-0+deb8u1 [81.2 kB]
Del libgnutls-deb0-28 3.3.8-6+deb8u4 [625 kB]
Del postfix-pcre 2.11.3-1 [276 kB]
Del libwbclient0 2:4.2.14+dfsg-0+deb8u2 [117 kB]
Del libsystemd0 215-17+deb8u6 [85.5 kB]
Del udev 215-17+deb8u6 [850 kB]
Del systemd-sysv 215-17+deb8u6 [36.3 kB]
Del tzdata 2016j-0+deb8u1 [186 kB]
Del libtiff5 4.0.3-12.3+deb8u2 [197 kB]
Del libgdk-pixbuf2.0-0 2.31.1-2+deb8u5 [148 kB]
Del libdns-export100 1:9.9.5.dfsg-9+deb8u9 [397 kB]
Del php5-ldap 5.6.29+dfsg-0+deb8u1 [19.0 kB]
Del libgnutls-openssl27 3.3.8-6+deb8u4 [139 kB]
Del php5-cli 5.6.29+dfsg-0+deb8u1 [1,904 kB]
Del bind9-host 1:9.9.5.dfsg-9+deb8u9 [65.5 kB]
Del libc-bin 2.19-18+deb8u7 [1,206 kB]
Del dnsmasq 2.72-3+deb8u1 [15.8 kB]
Del rmilter 1.9.2+nmu1 [149 kB]
Del samba-common 2:4.2.14+dfsg-0+deb8u2 [269 kB]
Del libxrandr2 2:1.4.2-1 [31.7 kB]
Del dnsutils 1:9.9.5.dfsg-9+deb8u9 [113 kB]
Del libxml2 2.9.1+dfsg1-5+deb8u4 [705 kB]
Del libxpm4 1:3.5.11-1 [41.7 kB]
Del libcurl3-gnutls 7.38.0-4+deb8u5 [225 kB]
Del libisc95 1:9.9.5.dfsg-9+deb8u9 [149 kB]
Del libudev1 215-17+deb8u6 [53.3 kB]
Del dovecot-sieve 1:2.2.13-12~deb8u1 [728 kB]
Del libbind9-90 1:9.9.5.dfsg-9+deb8u9 [41.2 kB]
Del libxi6 2:1.7.4-1 [73.4 kB]
Del libraspberrypi-dev 1.20161215-1 [397 kB]
Del php5-mysql 5.6.29+dfsg-0+deb8u1 [52.2 kB]
Del libperl5.20 5.20.2-3+deb8u6 [1,354 B]
Del git 1:2.1.4-2.1+deb8u2 [2,725 kB]
Del libisccfg-export90 1:9.9.5.dfsg-9+deb8u9 [37.9 kB]
Del libxcursor1 1:1.1.14-1 [34.7 kB]
Del raspi-config 20161207 [17.7 kB]
Del libraspberrypi-bin 1.20161215-1 [331 kB]
Del ssowat 2.6.0 [396 kB]
Del dnsmasq-base 2.72-3+deb8u1 [374 kB]
Del libdns100 1:9.9.5.dfsg-9+deb8u9 [599 kB]
Del php5-intl 5.6.29+dfsg-0+deb8u1 [92.6 kB]
Del libc6-dev 2.19-18+deb8u7 [1,724 kB]
Del nginx-extras 1.6.2-5+deb8u4 [516 kB]
Del libraspberrypi0 1.20161215-1 [842 kB]
Del postfix 2.11.3-1 [1,293 kB]
Del sudo-ldap 1.8.10p3-1+deb8u3 [858 kB]
Del nginx-common 1.6.2-5+deb8u4 [88.1 kB]
Del dovecot-core 1:2.2.13-12~deb8u1 [2,412 kB]
Del libxfixes3 1:5.0.1-2 [19.6 kB]
Del libc-dev-bin 2.19-18+deb8u7 [231 kB]
Del libcups2 1.7.5-11+deb8u1 [253 kB]
Del libraspberrypi-doc 1.20161215-1 [31.4 MB]
Del mariadb-server-core-10.0 10.0.29-0+deb8u1 [4,186 kB]
Del libicu52 52.1-8+deb8u4 [6,556 kB]
Del multiarch-support 2.19-18+deb8u7 [180 kB]
Del moulinette 2.5.1 [49.3 kB]
Del libmilter1.0.1 8.14.4-8+deb8u1 [235 kB]
Del ldap-utils 2.4.40+dfsg-1 [175 kB]
Del raspberrypi-bootloader 1.20161215-1 [3,260 kB]
Del slapd 2.4.40+dfsg-1 [1,288 kB]
Del libxslt1.1 1.1.28-2+deb8u2 [213 kB]
Del dovecot-ldap 1:2.2.13-12~deb8u1 [542 kB]
Del libgtk2.0-0 2.24.25-3+deb8u1 [2,015 kB]
Del pi-bluetooth 0.1.2 [3,398 B]
Del libc6 2.19-18+deb8u7 [4,082 kB]
Del php5-curl 5.6.29+dfsg-0+deb8u1 [24.5 kB]
Del libisccc90 1:9.9.5.dfsg-9+deb8u9 [34.3 kB]
Del libc6-dbg 2.19-18+deb8u7 [3,179 kB]
Del libgraphite2-3 1.3.6-1~deb8u1 [62.5 kB]
Del systemd 215-17+deb8u6 [2,212 kB]
Del nscd 2.19-18+deb8u7 [237 kB]
Del dovecot-managesieved 1:2.2.13-12~deb8u1 [563 kB]
Del php5-readline 5.6.29+dfsg-0+deb8u1 [11.2 kB]
Del libmysqlclient18 5.5.54-0+deb8u1 [622 kB]
Del php5-fpm 5.6.29+dfsg-0+deb8u1 [1,914 kB]
Del libisccfg90 1:9.9.5.dfsg-9+deb8u9 [50.4 kB]
Del libgdk-pixbuf2.0-common 2.31.1-2+deb8u5 [294 kB]
Del mariadb-server 10.0.29-0+deb8u1 [16.8 kB]
Del libgd3 2.1.0-5+deb8u8 [127 kB]
Del postfix-ldap 2.11.3-1 [281 kB]
Del mariadb-client-core-10.0 10.0.29-0+deb8u1 [718 kB]
Del libio-socket-ssl-perl 2.002-2+deb8u2 [172 kB]
Del libgtk2.0-bin 2.24.25-3+deb8u1 [534 kB]
Del libisc-export95 1:9.9.5.dfsg-9+deb8u9 [124 kB]
Del liblwres90 1:9.9.5.dfsg-9+deb8u9 [47.7 kB]
Del locales 2.19-18+deb8u7 [3,946 kB]
Del libunbound2 1.4.22-3+deb8u2 [266 kB]
Del dns-root-data 2014060201+2 [14.9 kB]
Del libasound2-data 1.0.28-1+rpi2 [65.2 kB]
Del dovecot-lmtpd 1:2.2.13-12~deb8u1 [540 kB]
Del ca-certificates 20141019+deb8u2 [207 kB]
Del procmail 3.22-24 [128 kB]
Del mariadb-server-10.0 10.0.29-0+deb8u1 [3,426 kB]
Del php5-mcrypt 5.6.29+dfsg-0+deb8u1 [13.4 kB]
Del rsync 3.1.1-3 [373 kB]
Del yunohost-admin 2.5.0 [8,555 kB]
Del mariadb-common 10.0.29-0+deb8u1 [17.1 kB]
Del libonig2 5.9.5-3.2 [101 kB]

Ca aide ?

après ça j’ai tenté une réinstallation de nextcloud et ça a fonctionné. Même si l’installation en elle-même (à travers l’interface) a pris beaucoup de temps (15 minutes environ)
je vais tester tout ça de ce pas

merci