Universal Media Server port


My YunoHost server

YunoHost version: (stable)
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no


I run a Yunohost (stable) on a machine at home. It uses a public IP address through a VPN I have with a VPS. Every app works great.

I installed the Universal Media Server app (just updated it to 10.19.0~ynh1) but it does not work, there is a problem with the port (5001). I opened the port in the same way I open ports for other apps (Yunohost firewall, VPN client, VPN server and VPS) and restarted correspondent services. However, Yunohost diagnosis reads “Port 5001 is not reachable from outside.”

I can also see the Yunohost firewall shows a red cross for port 5001 in the UPnP column.

I wanted to test if I get the same problem when changing the app port. In order to do so, I edit the file /home/yunohost.app/ums/.config/UMS.conf but I cannot do the test because when I restart the ums service the UMS.conf file is restored to its default values.

Any suggestion?

Thank you!

I’m the maintainer of the app.
Apart of the warnings in the diagnosis, is there any issue with the app?
To update the conf file, you have to first stop the service, then change the conf file, the restart the service, otherwise it is overwritten by ums.

When you say «it does not work » do you mean you can’t access the web interface or do you mean it is not detected by a renderer (like VLC or a TV or whatever)or both?
To be accessible by a renderer, the app has to be public otherwise the renderer fails on the sso portal
At home, I did not open port 5001 as I don’t want it to be accessible from outside and the app work without issue even with the warning.
On the warning, I have the same issue at home with some ports that are open and still on the diagnosis: so I would say this is more an issue from the diagnosis functionality.

Hey! Thank you for your message!

Yes, I cannot see any video. I can access the web interface, I can browse into the share/video directory, but nothing is shown, it looks empty (I stored my videos at /home/yunohost.multimedia/share/Video).
And sometimes I receive a 502 Bad Gateway nginx message.

Thank you.

What kind of file permissions are needed and where?
Or do you mean the app needs the Yunohost Visitors permission?
I have tried different options with no luck.

If you can access the web interface, there is no need to tweak the port I would say.
Can you check which path are set in the UMS.conf file for settings folders and folders_monitored?
There was a bug that switch the folder one or two release ago, I thought I workaround it, but maybe not in your case?

The 502 error may happen after a restart: the process can take quite a long time to scan the movies, and as long as it is not finish, you cannot access ums.
If it happens randomly… Well,I don’t know, would need to check the log.

Yes, the app requires Visitor permission (= “public”), but only in the case you want to cast your video on a renderer, like a TV, a VLC player on a computer, etc via UPnP. You don’t need to change it if you plan to use only the web interface.

It works now!

UMS was pointing at /home/yunohost.multimedia/share/
which included the Music directory with many files. I changed UMS configuration so that now it points directly to /home/yunohost.multimedia/share/Video and now I can see the videos.

I don’t really understand the root of the problem but now it works for my videos, which is enough for me. Maybe it was related to the size of that Music directory, I don’t know.

During my research I also found that UMS does not like special characters. I had to rename some files.

Many thanks for your help and explanations @Krakinou !

By the way, what is the difference between folders and folders_monitored?

One more thing, I found port 5001 is not needed at all, not even for external access.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.