Unable to use mail with multi domains

My YunoHost server

Hardware: Kimsufi KS-6 - Intel i5-750 - 16GB DDR3 1333 MHz - 2To SATA
YunoHost version: 3.6
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I run this instance for a year without issue. Recently I added a new domain and started install applications still without issue.

But I can’t receive email on the secondary domain. When I send an email to nouts@secondary.tld, the email is instantly return :

I’m sorry to have to inform you that your message could not
be delivered to one or more recipients. It’s attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

               The mail system

nouts@secondary.tld: host secondary.tld[xxx.xxx.xxx.xxx] said: 550 5.1.1
nouts@secondary.tld: Recipient address rejected: User unknown in virtual
mailbox table (in reply to RCPT TO command)

I’m also unable to register new email adress ending with @secondary.tld under my yunohost dashboard.

I can see this log in postfix :

=> /var/log/mail.log <==
Apr 5 19:32:52 primary postfix/smtpd[28941]: NOQUEUE: reject: RCPT from xxx.xxx.xxx.xxx: 550 5.1.1 nouts@secondary.tld Recipient address rejected: User unknown in virtual mailbox table; from=nouts@gmail.com to=nouts@secondary.tld proto=ESMTP helo=<gmail.com>

Hmokay, not sure where the issue is exactly …

  • I suppose you did add secondary.tld as a yunohost domain, right ?
  • Are there any special char in secondary.tld ?
  • Can you check that your postfix conf is up to date with yunohost tools regen-conf postfix --dry-run -d ?

To be clear: the error you are seeing are expected if the alias or mail address has not been defined … But what’s curious is that the SSO refuses to add the alias ?

Hi, thanks for your reply Aleks.

  • I added the secondary domain just like I added other subdomains from the primary.tld, and nothing more. I configure my DNS provider the same way I did with the main domain.
  • Both domains are plain lowercase text without accent. Just [a-z].
  • regen-conf on postfix return nothing (directly back to prompt shell)

I ran a force regen-conf on metronome, fail2ban and dnsmasq as they were diffs.
The error was still here.

And then, I was in the admin panel and I edited my user aliases from there. It worked. I can see the alias from my user panel. And now I’m able to add more alias directly from the user panel.
I tested the send email and they are delivered correctly.
Not sure what fixed it. (I’m disappointed I didn’t think about that before ^^’)

TL;DR I just edited from the admin panel. It worked

This can be closed. I can provide log or run command if you wish to dig this deeper otherwise.

Hmokay … maybe somehow the new domain wasn’t properly propagated to ssowat ? x_X Maybe a nginx reload needed … but that’s pretty weird, should already happen in the code. I’m really curious to know if it does work now from the SSO ? (Though it’s okay if you’re lazy to test)

The SSO ? Is that what I called the user panel ? My screenshot on my first post ?
Yes it work from there.

Yes, the user panel, sorry for the technical term :stuck_out_tongue_winking_eye: So it didn’t work before but now it does ? (Just to be sure so that’s probably something not correctly propagated)

Exactly. It didn’t but now it does.

FTR, I need to edit from the admin panel for every users that want aliases on the secondary domain.
It’s like, I need to “unlock” the secondary domain for an account from the admin panel once, and then user can do it on their own. So this issue is tied to accounts somehow.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.