Unable to update YunoHost

:uk: :us:

My YunoHost server

Hardware: Vultr High Frequency 1GB RAM, 1vCPU, 32GB SSD
YunoHost version:
I have access to my server : Through SSH + Through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : No

Description of my issue

Hi there,

I am unable to update my YunoHost instance to the latest version. Currently, I am running version


  • When I go to the ‘System update’ page, it says “All system packages are up to date!”
  • When I run the Linux update commands, it says everything is updated.

On the System Update page, the apps with new versions are listed and when I click on the upgrade button it says:

Requirements are not met for searx, the package yunohost ( must be >= 4.2.4

Question: How do I upgrade my YunoHost instance to the latest version?

PS. I have tried searching in the forum already and I have tried everything mentioned there.

Let’s look at the output of these commands :

sudo apt policy yunohost
# Here we put 'install' but this actually tells apt to explicitly upgrade yunohost
sudo apt install yunohost

Hi Aleks,

Thanks for the response.

The following command:

sudo apt policy yunohost

Gave the following output:

  Version table:
 *** 100
        100 /var/lib/dpkg/status

And the second command:

sudo apt install yunohost

Gave the following output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
yunohost is already the newest version (
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Update: So after spending many hours reading online solutions I decided to reinstall YunoHost on a new server. It took me less than 30 minutes to get it running with the apps! Much much better than the many hours I spent on troubleshooting the issues on the older server!

TL;DR Re-installing YunoHost is an easier way to go!

Hmpf wokay but it just looks like your /etc/apt/sources.list.d/yunohost.list file disappeared, or something / someone commented the line inside it … does that rings any bell to you ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.